ITeddsDocumentsAdd3 Method |
Add a new document using the specified Calc Item, input variables and pre-calculated RTF
Namespace: Tekla.Structural.InteropAssemblies.Tedds
Assembly: Tedds.TeddsIA (in Tedds.TeddsIA.dll) Version: 26.0.0.1
Syntax
ITeddsDocument Add3( string documentName, string libraryFileName, string libraryItemName, string VariablesXml, string outputRtf )
Parameters
- documentName
- Type: SystemString
Name for the new document - libraryFileName
- Type: SystemString
Name of the Calc Library file in which the Calc Item exists - libraryItemName
- Type: SystemString
Short name of the Calc Item which is used to start the calculation - VariablesXml
- Type: SystemString
Input variables for the document which have been created using an existing document or via the Tedds Calculator API . - outputRtf
- Type: SystemString
Output in RTF format which has been retrieved from an existing document or via the Tedds Calculator API.
Return Value
Type: ITeddsDocumentThe new document
Remarks
The input variables XML and the output RTF can be directly retrieved by using the Tedds Calculator API.
See Also