ICalcValueToString Method

Returns the objects value represented as a string.

Namespace:  Tekla.Structural.InteropAssemblies.TeddsCalc
Assembly:  Tedds.TeddsCalcIA (in Tedds.TeddsCalcIA.dll) Version: 25.0.0.0
Syntax
string ToString(
	[OptionalAttribute] string units,
	CalcValueFormat format = CalcValueFormat.Fixed,
	int precision = 3
)

Parameters

units (Optional)
Type: SystemString
Units to use for converting the numeric value, if omitted the value will be represented in base units.
format (Optional)
Type: Tekla.Structural.InteropAssemblies.TeddsCalcCalcValueFormat
format Expression text format to use for representing the numerical value (E = Engineering, F = Fixed, G = General, S = Scientific, O = Data Input/Output, U = User input)
precision (Optional)
Type: SystemInt32
Numeric precision to use

Return Value

Type: String
The objects value as a string
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next