CalcProgressEvent Enumeration |
Progress bar modes
Namespace: Tekla.Structural.InteropAssemblies.TeddsCalc
Assembly: Tedds.TeddsCalcIA (in Tedds.TeddsCalcIA.dll) Version: 25.0.0.0
Syntax
Members
Member name | Value | Description | |
---|---|---|---|
ProgressReset | 0 | Reset position to 0 | |
ProgressSetPos | 1 | Set position | |
ProgressSetText | 2 | Set text | |
ProgressDisable | 3 | Disable | |
ProgressEnable | 4 | Enable | |
ProgressGetStatus | 5 | Get state | |
ProgressAddOutput | 6 | Add item to output log | |
ProgressClearOutput | 7 | Clear output log | |
ProgressFinished | 8 | Notify finish | |
ProgressSetDestroyOnFinish | 9 | Set flag to destroy on finish | |
ProgressSetHideOnFinish | 10 | Set flag to hide on finish | |
ProgressShow | 11 | Show progress log | |
ProgressHide | 12 | Hide progress log |
See Also