![]() | UserPropertyOption Class |
The UserPropertyOption class contains the properties of a user property value option.

SystemObject
Tekla.Structures.CatalogsUserPropertyOption
Tekla.Structures.CatalogsUserPropertyOption
Namespace: Tekla.Structures.Catalogs
Assembly: Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2025.0.0-alpha00045580+dc02c3918546f1e94eb2d3b13ea99057fb3313e0

The UserPropertyOption type exposes the following members.

Name | Description | |
---|---|---|
![]() | UserPropertyOption | Initializes a new instance of the UserPropertyOption class |

Name | Description | |
---|---|---|
![]() | DoubleValue |
The double value.
|
![]() | IntValue |
The integer value.
|
![]() | OptionLabel |
The option name.
|
![]() | OptionLabelTranslated |
The translated option name.
|
![]() | StringValue |
The string value.
|