![]() | CatalogHandlerImportBoltItems Method |
Imports bolt items and their assembly information (*.bass) from folder to bolt assembly catalog and bolt catalog.
Import overrides the existing bolts in the catalog without any warnings.
Namespace: Tekla.Structures.Catalogs
Assembly: Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2025.0.0-alpha00045580+dc02c3918546f1e94eb2d3b13ea99057fb3313e0

Parameters
- path
- Type: SystemString
The path to be used for import.
Return Value
Type: Booleantrue if successful.

using System; using Tekla.Structures.Catalogs; public class Example { public void Example1() { if (new CatalogHandler().ImportBoltItems(System.IO.Path.GetTempPath())) Console.WriteLine("Bolts and bolt assemblies imported successfully to catalog."); } }