WpfOkApplyModifyGetOnOffCancel Class |
Interaction logic for WpfOkApplyModifyGetOnOffCancel.xaml
WpfOkApplyModifyGetOnOffCancel
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
Tekla.Structures.Dialog.UIControlsWpfOkApplyModifyGetOnOffCancel
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
Tekla.Structures.Dialog.UIControlsWpfOkApplyModifyGetOnOffCancel
Namespace: Tekla.Structures.Dialog.UIControls
Assembly: Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The WpfOkApplyModifyGetOnOffCancel type exposes the following members.
Constructors
Name | Description | |
---|---|---|
WpfOkApplyModifyGetOnOffCancel |
Constructor
|
Methods
Name | Description | |
---|---|---|
InitializeComponent |
InitializeComponent
|
Events
Name | Description | |
---|---|---|
ApplyClicked |
The ApplyClicked event is raised when the Apply button is clicked.
| |
CancelClicked |
The CancelClicked event is raised when the Cancel button is clicked.
| |
GetClicked |
The GetClicked event is raised when the Get button is clicked.
| |
ModifyClicked |
The ModifyClicked event is raised when the Modify button is clicked.
| |
OkClicked |
The OkClicked event is raised when the Ok button is clicked.
| |
OnOffClicked |
The OnOffClicked event is raised when the OnOff button is clicked.
|
See Also