WpfFilterCheckBox Class

The WpfFilterAttribute class represents a checkbox control for enabling/disabling dialog attributes defined with StructuresFieldAttribute.
Inheritance Hierarchy
SystemObject
  System.Windows.ThreadingDispatcherObject
    System.WindowsDependencyObject
      System.Windows.MediaVisual
        System.WindowsUIElement
          System.WindowsFrameworkElement
            System.Windows.ControlsControl
              System.Windows.ControlsContentControl
                System.Windows.Controls.PrimitivesButtonBase
                  System.Windows.Controls.PrimitivesToggleButton
                    System.Windows.ControlsCheckBox
                      Tekla.Structures.Dialog.UIControlsWpfFilterCheckBox

Namespace:  Tekla.Structures.Dialog.UIControls
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public class WpfFilterCheckBox : CheckBox

The WpfFilterCheckBox type exposes the following members.

Constructors
  NameDescription
Public methodWpfFilterCheckBox
Initiates a new instance of the control.
Top
Properties
  NameDescription
Public propertyAttributeName
Dialog attribute name defined with StructuresFieldAttribute
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next