WpfCreateApplyCancel Class |
Interaction logic for WPFCreateAppyCancel.xaml.
Control is meant to be used with non-dependent plug-ins
WpfCreateApplyCancel
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
Tekla.Structures.Dialog.UIControlsWpfCreateApplyCancel
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
Tekla.Structures.Dialog.UIControlsWpfCreateApplyCancel
Namespace: Tekla.Structures.Dialog.UIControls
Assembly: Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The WpfCreateApplyCancel type exposes the following members.
Constructors
Name | Description | |
---|---|---|
WpfCreateApplyCancel |
Constructor
|
Methods
Name | Description | |
---|---|---|
InitializeComponent |
InitializeComponent
|
Events
Name | Description | |
---|---|---|
ApplyClicked |
The ApplyClicked event is raised when the Apply button is clicked.
| |
CancelClicked |
The CancelClicked event is raised when the Cancel button is clicked.
| |
CreateClicked |
The ApplyClicked event is raised when the Apply button is clicked.
|
See Also