WpfComponentCatalog Class |
The WpfComponentCatalog class represents a group of controls to select components
using the component catalog.
WpfComponentCatalog
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
Tekla.Structures.Dialog.UIControlsWpfComponentCatalog
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
Tekla.Structures.Dialog.UIControlsWpfComponentCatalog
Namespace: Tekla.Structures.Dialog.UIControls
Assembly: Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The WpfComponentCatalog type exposes the following members.
Constructors
Name | Description | |
---|---|---|
WpfComponentCatalog |
Initializes a new instance of the WpfComponentCatalog class.
|
Properties
Name | Description | |
---|---|---|
ButtonHeight |
Gets and sets the height of the button control.
| |
ButtonText |
Gets and sets the text of the button control.
| |
ButtonWidth |
Gets and sets the width of the button control.
| |
SelectedName |
Gets or sets the selected component name in the control.
| |
SelectedNumber |
Gets or sets the selected component number in the control.
|
Methods
Name | Description | |
---|---|---|
InitializeComponent |
InitializeComponent
|
Events
Name | Description | |
---|---|---|
SelectClicked |
The SelectClicked event is raised when the Select button is clicked.
| |
SelectionDone |
The SelectionDone event is raised when the selection has been done.
|
See Also