Weld Class |
The Weld class represents a normal weld in the model.
A normal weld has a main part and a secondary part.
Inheritance Hierarchy
SystemObject
Tekla.Structures.ModelObject
Tekla.Structures.ModelModelObject
Tekla.Structures.ModelBaseWeld
Tekla.Structures.ModelWeld
Tekla.Structures.ModelObject
Tekla.Structures.ModelModelObject
Tekla.Structures.ModelBaseWeld
Tekla.Structures.ModelWeld
Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The Weld type exposes the following members.
Constructors
Properties
Name | Description | |
---|---|---|
AroundWeld |
Gets or sets a value indicating whether
ConnectAssemblies |
Gets or sets a value indicating whether
to connect a part or an assembly as a secondary part (false)
Direction | Defines the Weld edge search direction normalized to length 1000.0. Overrides Position if set. | |
Position | Defines the position. Use of Direction is preferred over this. | |
ShopWeld |
Gets or sets a value indicating whether
Methods
Name | Description | |
---|---|---|
GetAllReportProperties |
Retrieves all properties for the model object in one hashtable.
GetAllUserProperties |
Retrieves all properties for the model object in one hashtable.
GetDoubleReportProperties |
Retrieves multiple double report properties for the model object. It is faster
GetIntegerReportProperties |
Retrieves multiple integer report properties for the model object. It is faster
GetLogicalWeld |
Gets the logical weld where the weld belongs. Returns false if
the weld does not belong to any logical weld.
GetStringReportProperties |
Retrieves multiple string report properties for the model object. It is faster
GetWeldGeometries |
Method for getting weld seam geometries.
Insert | Inserts the weld into the model database. All the attributes must be set. (Overrides ModelObjectInsert.) | |
Modify |
Modifies the existing weld in the model database to match the current one.
The modification cannot be done if the weld is a part of a logical weld.
(Overrides ModelObjectModify.) | |
SetLabel |
Sets a label for an object when a new instance is created, this method must be called before Insert.
Examples
using Tekla.Structures.Model; using Tekla.Structures.Geometry3d; public class Example { public void Example1() { Point Beam1P1 = new Point( 0, 12000, 0); Point Beam1P2 = new Point(3000, 12000, 0); Point Beam2P1 = new Point(3000, 12000, 0); Point Beam2P2 = new Point(3000, 18000, 0); Beam Beam1 = new Beam(Beam1P1, Beam1P2); Beam Beam2 = new Beam(Beam2P1, Beam2P2); Beam1.Profile.ProfileString = "HEA400"; Beam1.Finish = "PAINT"; Beam1.Name = "Beam 1"; Beam2.Name = "Beam 2"; Beam1.Insert(); Beam2.Insert(); Weld Weld = new Weld(); Weld.MainObject = Beam1; Weld.SecondaryObject = Beam2; Weld.TypeAbove = BaseWeld.WeldTypeEnum.WELD_TYPE_SQUARE_GROOVE_SQUARE_BUTT; Weld.Insert(); Weld.LengthAbove = 12; Weld.TypeBelow = BaseWeld.WeldTypeEnum.WELD_TYPE_SLOT; Weld.Modify(); } }
See Also