Weld Class |
The Weld class represents a normal weld in the model.
A normal weld has a main part and a secondary part.
Inheritance Hierarchy
SystemObject
Tekla.Structures.ModelObject
Tekla.Structures.ModelModelObject
Tekla.Structures.ModelBaseWeld
Tekla.Structures.ModelWeld
Tekla.Structures.ModelObject
Tekla.Structures.ModelModelObject
Tekla.Structures.ModelBaseWeld
Tekla.Structures.ModelWeld
Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The Weld type exposes the following members.
Constructors
Properties
Name | Description | |
---|---|---|
AdditionalSizeAbove | Gets or sets the additional size above for combination welds. (Inherited from BaseWeld.) | |
AdditionalSizeBelow | Gets or sets the additional size below for combination welds. (Inherited from BaseWeld.) | |
AngleAbove | Gets or sets the angle above. (Inherited from BaseWeld.) | |
AngleBelow | Gets or sets the angle below. (Inherited from BaseWeld.) | |
AroundWeld |
Gets or sets a value indicating whether
the weld is an around weld (true) or an edge weld (false).
(Inherited from BaseWeld.) | |
ConnectAssemblies |
Gets or sets a value indicating whether
to connect a part or an assembly as a secondary part (false)
or as a sub-assembly (true).
(Inherited from BaseWeld.) | |
ContourAbove | Gets or sets the contour above. (Inherited from BaseWeld.) | |
ContourBelow | Gets or sets the contour below. (Inherited from BaseWeld.) | |
Direction | Defines the Weld edge search direction normalized to length 1000.0. Overrides Position if set. | |
EffectiveThroatAbove | Gets or sets the effective throat above. (Inherited from BaseWeld.) | |
EffectiveThroatBelow | Gets or sets the effective throat below. (Inherited from BaseWeld.) | |
ElectrodeClassification | Gets or sets the weld electrode classification. (Inherited from BaseWeld.) | |
ElectrodeCoefficient | Gets or sets the electrode strength coefficient. (Inherited from BaseWeld.) | |
ElectrodeStrength | Gets or sets the electrode strength. (Inherited from BaseWeld.) | |
FinishAbove | Gets or sets the finish above. (Inherited from BaseWeld.) | |
FinishBelow | Gets or sets the finish below. (Inherited from BaseWeld.) | |
Identifier |
The identifier of the object.
(Inherited from Object.) | |
IncrementAmountAbove |
Gets or sets the increment amount above.
(Inherited from BaseWeld.) | |
IncrementAmountBelow |
Gets or sets the increment amount below.
(Inherited from BaseWeld.) | |
IntermittentType |
Gets or sets the weld intermittent type.
(Inherited from BaseWeld.) | |
IsUpToDate | Gets if the object does not have a modification which is not shared. (Inherited from ModelObject.) | |
LengthAbove | Gets or sets the length above. (Inherited from BaseWeld.) | |
LengthBelow | Gets or sets the length below. (Inherited from BaseWeld.) | |
MainObject | Gets or sets the main part of the weld. (Inherited from BaseWeld.) | |
ModificationTime | Gets latest time of the object was modified or created. (Inherited from ModelObject.) | |
NDTInspection | Gets or sets the NDT inspection level. (Inherited from BaseWeld.) | |
PitchAbove | Gets or sets the pitch above. (Inherited from BaseWeld.) | |
PitchBelow | Gets or sets the pitch below. (Inherited from BaseWeld.) | |
Placement |
Gets or sets the weld placement.
(Inherited from BaseWeld.) | |
Position | Defines the position. Use of Direction is preferred over this. | |
PrefixAboveLine | Gets or sets the size prefix above the line. (Inherited from BaseWeld.) | |
PrefixBelowLine | Gets or sets the size prefix below the line. (Inherited from BaseWeld.) | |
Preparation |
Gets or sets the weld preparation.
(Inherited from BaseWeld.) | |
ProcessType | Gets or sets the process type. (Inherited from BaseWeld.) | |
ReferenceText | Gets or sets the reference text. (Inherited from BaseWeld.) | |
RootFaceAbove | Gets or sets the root face above. (Inherited from BaseWeld.) | |
RootFaceBelow | Gets or sets the root face below. (Inherited from BaseWeld.) | |
RootOpeningAbove | Gets or sets the root opening above. (Inherited from BaseWeld.) | |
RootOpeningBelow | Gets or sets the root opening below. (Inherited from BaseWeld.) | |
SecondaryObject | Gets or sets the secondary part of the weld. (Inherited from BaseWeld.) | |
ShopWeld |
Gets or sets a value indicating whether
the weld is a shop weld (true) or a site weld (false).
(Inherited from BaseWeld.) | |
SizeAbove | Gets or sets the size above. (Inherited from BaseWeld.) | |
SizeBelow | Gets or sets the size below. (Inherited from BaseWeld.) | |
Standard | Obsolete. Gets or sets the weld detail/standard. (Inherited from BaseWeld.) | |
StitchWeld | Obsolete.
Gets or sets a value indicating whether
the weld is stitched (true) or not stitched (false).
(Inherited from BaseWeld.) | |
TypeAbove | Gets or sets the type above. (Inherited from BaseWeld.) | |
TypeBelow | Gets or sets the type below. (Inherited from BaseWeld.) | |
WeldNumber | Gets the weld number. (Inherited from BaseWeld.) | |
WeldNumberPrefix | Gets or sets the weld number prefix. (Inherited from BaseWeld.) |
Methods
Name | Description | |
---|---|---|
CompareTo |
Compares Identifiers of model objects.
(Inherited from ModelObject.) | |
Delete | Deletes the weld instance with the given identifier from the model database. (Overrides ModelObjectDelete.) | |
Equals |
Check if Identifiers of model objects are same.
(Inherited from ModelObject.) | |
GetAllReportProperties |
Retrieves all properties for the model object in one hashtable.
Type for the returned value must be checked using type casting.
(Inherited from ModelObject.) | |
GetAllUserProperties |
Retrieves all properties for the model object in one hashtable.
Type for the returned value must be checked using type casting.
(Inherited from ModelObject.) | |
GetChildren |
Returns an enumerator of all the children model objects.
(Inherited from ModelObject.) | |
GetCoordinateSystem |
Returns the coordinate system for the given model object.
(Inherited from ModelObject.) | |
GetDoubleReportProperties |
Retrieves multiple double report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) | |
GetDoubleUserProperties |
Retrieves all double properties for the model object.
(Inherited from ModelObject.) | |
GetDynamicStringProperty |
Gets a dynamic string property from the model object.
(Inherited from ModelObject.) | |
GetFatherComponent |
Returns the father component of the model object.
(Inherited from ModelObject.) | |
GetHierarchicObjects |
Returns an enumerator of all the connected hierarchic objects.
(Inherited from ModelObject.) | |
GetIntegerReportProperties |
Retrieves multiple integer report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) | |
GetIntegerUserProperties |
Retrieves all integer properties for the model object.
(Inherited from ModelObject.) | |
GetLogicalWeld |
Gets the logical weld where the weld belongs. Returns false if
the weld does not belong to any logical weld.
| |
GetPhase |
Retrieves the phase of the model object (the phase number, the phase name,
the phase comment and whether the phase is the current one or not).
(Inherited from ModelObject.) | |
GetReportProperty(String, Double) |
Retrieves a double property of the report for the model object.
(Inherited from ModelObject.) | |
GetReportProperty(String, Int32) |
Retrieves an integer property of the report for the model object.
(Inherited from ModelObject.) | |
GetReportProperty(String, String) |
Retrieves a string property of the report for the model object.
(Inherited from ModelObject.) | |
GetSolid |
Method for getting the weld solid.
(Inherited from BaseWeld.) | |
GetStringReportProperties |
Retrieves multiple string report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) | |
GetStringUserProperties |
Retrieves all string properties for the model object.
(Inherited from ModelObject.) | |
GetUserProperty(String, Double) |
Retrieves a double property for the model object.
(Inherited from ModelObject.) | |
GetUserProperty(String, Int32) |
Retrieves an integer property for the model object.
(Inherited from ModelObject.) | |
GetUserProperty(String, String) |
Retrieves a string property for the model object.
(Inherited from ModelObject.) | |
GetWeldGeometries |
Method for getting weld seam geometries.
Every result represents one individual seam geometry in current weld.
(Inherited from BaseWeld.) | |
Insert | Inserts the weld into the model database. All the attributes must be set. (Overrides ModelObjectInsert.) | |
Modify |
Modifies the existing weld in the model database to match the current one.
The modification cannot be done if the weld is a part of a logical weld.
(Overrides ModelObjectModify.) | |
Select | Selects a weld from the model database. The weld identifier must be set. (Overrides ModelObjectSelect.) | |
SetDynamicStringProperty |
Sets a dynamic string property for the model object.
(Inherited from ModelObject.) | |
SetLabel |
Sets a label for an object when a new instance is created, this method must be called before Insert.
The label is used in plug-ins for identifying the changed object in modification.
(Inherited from ModelObject.) | |
SetPhase |
Sets the phase of the model object.
(Inherited from ModelObject.) | |
SetUserProperties |
Sets multiple properties for the model object.
(Inherited from ModelObject.) | |
SetUserProperty(String, Double) |
Sets a double property for the model object.
(Inherited from ModelObject.) | |
SetUserProperty(String, Int32) |
Sets an integer property for the model object.
(Inherited from ModelObject.) | |
SetUserProperty(String, String) |
Sets a string property for the model object.
(Inherited from ModelObject.) |
Examples
using Tekla.Structures.Model; using Tekla.Structures.Geometry3d; public class Example { public void Example1() { Point Beam1P1 = new Point( 0, 12000, 0); Point Beam1P2 = new Point(3000, 12000, 0); Point Beam2P1 = new Point(3000, 12000, 0); Point Beam2P2 = new Point(3000, 18000, 0); Beam Beam1 = new Beam(Beam1P1, Beam1P2); Beam Beam2 = new Beam(Beam2P1, Beam2P2); Beam1.Profile.ProfileString = "HEA400"; Beam1.Finish = "PAINT"; Beam1.Name = "Beam 1"; Beam2.Name = "Beam 2"; Beam1.Insert(); Beam2.Insert(); Weld Weld = new Weld(); Weld.MainObject = Beam1; Weld.SecondaryObject = Beam2; Weld.TypeAbove = BaseWeld.WeldTypeEnum.WELD_TYPE_SQUARE_GROOVE_SQUARE_BUTT; Weld.Insert(); Weld.LengthAbove = 12; Weld.TypeBelow = BaseWeld.WeldTypeEnum.WELD_TYPE_SLOT; Weld.Modify(); } }
See Also