Weld Class |
The Weld class represents weldings in drawing views that refer to actual welds in the model database.
It has properties and methods to control the graphical representation of welding lines.
Instances of Weld class cannot be inserted with code. These appear in drawings when views are created/updated.
To modify its graphical representation, attributes of Weld class can use .welo setting files.
Inheritance Hierarchy
SystemObject
Tekla.Structures.DrawingDatabaseObject
Tekla.Structures.DrawingDrawingObject
Tekla.Structures.DrawingModelObject
Tekla.Structures.DrawingWeld
Tekla.Structures.DrawingDatabaseObject
Tekla.Structures.DrawingDrawingObject
Tekla.Structures.DrawingModelObject
Tekla.Structures.DrawingWeld
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The Weld type exposes the following members.
Properties
Name | Description | |
---|---|---|
Attributes |
The attributes of the weld.
For more information see WeldWeldAttributes.
ModelIdentifier |
The database identifier of the model object in the model database.
By using this identifier, it is possible to select the actual object
Methods
Name | Description | |
---|---|---|
Delete |
Deletes the drawing weld from the current drawing database.
GetUserProperty(String, Double) |
Gets a double property from the drawing object. The object has to be in a drawing before
GetUserProperty(String, Int32) |
Gets an integer property from the drawing object. The object has to be in a drawing before
GetUserProperty(String, String) |
Gets a string property from the drawing object. The object has to be in a drawing before
Insert |
NOT YET IMPLEMENTED.
Welding lines that refer to welds in the model database appear in views when drawing views are created/updated.
(Overrides DatabaseObjectInsert.) | |
IsEqual |
Compares the current object with an object of the same type.
Modify |
Calls the system to update/modify the weld.
Class can use .welo setting files to modify graphical representation of the welding lines.
(Overrides DatabaseObjectModify.) | |
Select |
Selects the drawing weld from the current drawing database.
SetUserProperty(String, Int32) |
Sets an integer property for the drawing object. The object has to be in a drawing before
SetUserProperty(String, String) |
Sets a string property for the drawing object. The object has to be in a drawing before
See Also