ViewViewMarkSymbolAttributes Constructor (Double, MarkSymbolShape, ViewLabelLineLengthType, Double)

Creates a new mark symbol attributes instance with the given size, shape, line length type and line length.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public ViewMarkSymbolAttributes(
	double size,
	MarkSymbolShape shape,
	ViewLabelLineLengthType lineLengthType,
	double lineLength
)

Parameters

size
Type: SystemDouble
The size of the mark symbol to be used.
shape
Type: Tekla.Structures.DrawingMarkSymbolShape
The shape of the mark symbol to be used.
lineLengthType
Type: Tekla.Structures.DrawingViewLabelLineLengthType
The line length type of the mark symbol to be used.
lineLength
Type: SystemDouble
The line length of the mark symbol to be used.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next