ViewViewAttributes Class

The ViewAttributes class contains the attributes for the view.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.DrawingAttributesBase
    Tekla.Structures.DrawingViewViewAttributes

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
[SerializableAttribute]
public sealed class ViewAttributes : AttributesBase

The ViewViewAttributes type exposes the following members.

Constructors
Properties
  NameDescription
Public propertyDatumLevel
The specified datum level. If ViewPlaneDatumPointForElevations is set to true when DatumLevel is set, the value of ViewPlaneDatumPointForElevations will change to false.
Public propertyFixedViewPlacing
Defines whether the view placing is fixed (true) or free (false).
Public propertyLabelPositionHorizontal
The horizontal position of the view label.
Public propertyLabelPositionVertical
The vertical position of the view label.
Public propertyLocationBy
Gets or sets the location by attribute. Value is ViewAttributes.LocationByModelOrigin, ViewAttributes.LocationByProjectBasePoint or guid of a Basepoint.
Public propertyMarkSymbolAttributes
The view mark symbol attributes.
Public propertyMarkSymbolColor
The color of the mark symbol (see DrawingColors for options).
Public propertyPartialProfileLength
Gets or sets the partial profile length.
Public propertyPartialProfileOffset
Gets or sets the partial profile offset
Public propertyPourView
Defines whether the view is pour view or not.
Public propertyReflectedView
Defines whether the view is reflected or not.
Public propertyScale
The view scale.
Public propertyShortening
Gets or sets the shortening attributes for the view.
Public propertyShowPartOpeningsOrRecessSymbol
Defines whether to show the openings/recess symbol or not.
Public propertyTagsAttributes
The attributes for view mark tags.
Public propertyTrueMarkSymbolColor
The true color (rgb enabled) of the mark symbol.
Public propertyUndeformedView
Defines whether the view is undeformed or not.
Public propertyUnfoldedView
Defines whether the view is unfolded or not.
Public propertyViewExtensionForNeighbourParts
The view extension for neighbour parts.
Public propertyViewPlaneDatumPointForElevations
Defines whether the datum point for elevations is view plane based (true) or specified (false). When set to false, the value of DatumLevel is used. When set to true, DatumLevel will be set to 0.0.
Top
Methods
Fields
  NameDescription
Public fieldStatic memberLocationByModelOrigin
A constant string defining that the view location is calculated by model origin.
Public fieldStatic memberLocationByProjectBasePoint
A constant string defining that the view location is calculated by project base point.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next