ViewMarkBasicTagAttributes Class |
The ViewMarkBasicTagAttributes class contains basic attributes for view mark tags.
Inheritance Hierarchy
SystemObject
Tekla.Structures.DrawingGenericAttributesBase
Tekla.Structures.DrawingViewMarkBasicTagAttributes
Tekla.Structures.DrawingSectionMarkBaseSectionMarkTagAttributes
Tekla.Structures.DrawingViewViewMarkTagAttributes
Tekla.Structures.DrawingGenericAttributesBase
Tekla.Structures.DrawingViewMarkBasicTagAttributes
Tekla.Structures.DrawingSectionMarkBaseSectionMarkTagAttributes
Tekla.Structures.DrawingViewViewMarkTagAttributes
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The ViewMarkBasicTagAttributes type exposes the following members.
Constructors
Name | Description | |
---|---|---|
ViewMarkBasicTagAttributes |
Creates a new mark tag attributes instance.
| |
ViewMarkBasicTagAttributes(Vector, TagLocation, ContainerElement) |
Creates a new mark tag attributes instance with the given offset, location and content.
|
Properties
Name | Description | |
---|---|---|
Location |
The location of the mark tag.
| |
Offset |
The offset of the mark tag.
| |
TagContent |
The tag content.
|
Methods
Name | Description | |
---|---|---|
IsEqual |
Compares the current object with an object of the same type.
(Overrides GenericAttributesBaseIsEqual(Object).) |
See Also