Vector Class |
The Vector class defines a direction and magnitude from the current origin.
Inheritance Hierarchy
Namespace: Tekla.Structures.Geometry3d
Assembly: Tekla.Structures (in Tekla.Structures.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The Vector type exposes the following members.
Constructors
Name | Description | |
---|---|---|
Vector |
Instantiates a zero length vector.
| |
Vector(Point) |
Instatiates a new vector with the given point.
| |
Vector(Double, Double, Double) |
Instantiates a vector with the given coordinates.
|
Methods
Name | Description | |
---|---|---|
CompareTo |
Compares two points. To use binarysearch somekind of sorting should be used.
(Inherited from Point.) | |
Cross(Vector) |
Returns a new cross product vector of the current vector and the given vector.
| |
Cross(Vector, Vector) |
Returns a new cross product vector of the given two vectors.
| |
Dot(Vector) |
Returns a dot product of the current vector and the given vector.
| |
Dot(Vector, Vector) |
Returns a dot product of the given two vectors.
| |
Equals |
Returns true if the current object and the given object are equal.
(Inherited from Point.) | |
GetAngleBetween |
Gets the angle (in radians) between the current vector and the given vector.
| |
GetHashCode |
Returns a hash code for the point.
Notice, in extremely rare cases, you might not get the same
hash code for two points even though they are considered equal! This
should, however, happen only in extremely rare cases!
(Inherited from Point.) | |
GetLength |
Gets the length (magnitude) of a vector.
| |
GetNormal |
Returns a new normalized equivalent of the current vector.
| |
Normalize |
Normalizes the vector using the length 1.0 (the length of a unit vector).
| |
Normalize(Double) |
Normalizes the vector using the given length.
| |
ToString |
Formats the 3D vector into a string with fixed decimals, in the following way: "(X, Y, Z)".
(Overrides PointToString.) | |
Translate |
Translates the point using the given vector.
(Inherited from Point.) | |
Zero |
Zeros all the members of the point.
(Inherited from Point.) |
Operators
Name | Description | |
---|---|---|
Multiply(Double, Vector) |
Calculates the multiplication of the given vector with the given scalar.
| |
Multiply(Vector, Double) |
Calculates the multiplication of the given vector with the given scalar.
|
Fields
Name | Description | |
---|---|---|
X |
The X-coordinate of the point.
(Inherited from Point.) | |
Y |
The Y-coordinate of the point.
(Inherited from Point.) | |
Z |
The Z-coordinate of the point.
(Inherited from Point.) |
See Also