UserPropertyItemEnumerator Class |
The UserPropertyItemEnumerator class allows to loop through the user property items.
Inheritance Hierarchy
Namespace: Tekla.Structures.Catalogs
Assembly: Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The UserPropertyItemEnumerator type exposes the following members.
Properties
Methods
Name | Description | |
---|---|---|
GetSize |
Returns the total amout of items.
| |
MoveNext |
Moves to the next item in the enumerator.
| |
Reset |
Resets the enumerator to the beginning.
|
Examples
The following example returns true if an item with the name "comment" has been found:
using Tekla.Structures.Catalogs; public class Example { public bool Example1() { bool Result = false; CatalogHandler CatalogHandler = new CatalogHandler(); if (CatalogHandler.GetConnectionStatus()) { UserPropertyItemEnumerator UserPropertyItemEnumerator = CatalogHandler.GetUserPropertyItems(); while (UserPropertyItemEnumerator.MoveNext()) { UserPropertyItem UserPropertyItem = UserPropertyItemEnumerator.Current as UserPropertyItem; if (UserPropertyItem.Name == "comment") { Result = true; break; } } } return Result; } }
See Also