UserPropertyFieldTypeEnum Enumeration

The user property field type.

Namespace:  Tekla.Structures.Catalogs
Assembly:  Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public enum UserPropertyFieldTypeEnum
Members
  Member nameValueDescription
FIELDTYPE_UNDEFINED0 The user property field type is undefined.
FIELDTYPE_NUMBER1 The user property field type is number.
FIELDTYPE_TEXT2 The user property field type is text.
FIELDTYPE_DISTANCE3 The user property field type is distance.
FIELDTYPE_PROFILE4 The user property field type is profile.
FIELDTYPE_MATERIAL5 The user property field type is material.
FIELDTYPE_TEXT_LIST_DISTANCE6 The user property field type is distance list.
FIELDTYPE_FILE_IN7 The user property field type is file in.
FIELDTYPE_FILE_OUT8 The user property field type is file out.
FIELDTYPE_BOLT_STANDARD9 The user property field type is bolt standard.
FIELDTYPE_BOLT_SIZE10 The user property field type is bolt size.
FIELDTYPE_RATIO11 The user property field type is ratio.
FIELDTYPE_STRAIN12 The user property field type is strain.
FIELDTYPE_ANGLE13 The user property field type is angle.
FIELDTYPE_DEFORMATION14 The user property field type is deformation.
FIELDTYPE_DIMENSION15 The user property field type is dimension.
FIELDTYPE_RADIUSOFINERTIA16 The user property field type is radius of inertia.
FIELDTYPE_AREA17 The user property field type is area.
FIELDTYPE_AREAPERLENGTH18 The user property field type is area/length.
FIELDTYPE_SECTIONMODULUS19 The user property field type is section modulus.
FIELDTYPE_MOMENTOFINERTIA20 The user property field type is moment of inertia.
FIELDTYPE_TORSIONCONSTANT21 The user property field type is torsion constant.
FIELDTYPE_WARPINGCONSTANT22 The user property field type is warping constant.
FIELDTYPE_FORCE23 The user property field type is force.
FIELDTYPE_WEIGHT24 The user property field type is weight.
FIELDTYPE_DISTRIBLOAD25 The user property field type is distributed load.
FIELDTYPE_SPRINGCONSTANT26 The user property field type is spring constant.
FIELDTYPE_SURFACELOAD27 The user property field type is surface load.
FIELDTYPE_STRENGTH28 The user property field type is strength.
FIELDTYPE_MODULUS29 The user property field type is modulus.
FIELDTYPE_DENSITY30 The user property field type is density.
FIELDTYPE_MOMENT31 The user property field type is moment.
FIELDTYPE_DISTRIBMOMENT32 The user property field type is distributed moment.
FIELDTYPE_ROTSPRINGCONST33 The user property field type is rotational spring constant.
FIELDTYPE_TEMPERATURE34 The user property field type is temperature.
FIELDTYPE_THERMDILATCOEFF35 The user property field type is thermal coefficient.
FIELDTYPE_ANALYSIS_RESTRAINT36 The user property field type is analysis restraint.
FIELDTYPE_VOLUME37 The user property field type is volume.
FIELDTYPE_REBAR_MAIN38 The user property field type is main reinforcement bar.
FIELDTYPE_REBAR_STIRRUP39 The user property field type is stirrup reinforcement bar.
FIELDTYPE_DATE40 The user property field type is date.
FIELDTYPE_DATE_TIME_SEC41 The user property field type is date and time with seconds.
FIELDTYPE_DATE_TIME_MIN42 The user property field type is date and time with minutes.
FIELDTYPE_STUD_STANDARD43 The user property field type is stud standard.
FIELDTYPE_STUD_SIZE44 The user property field type is stud size.
FIELDTYPE_STUD_LENGTH45 The user property field type is stud length.
FIELDTYPE_HOLE_TYPE46 The user property field type is hole type.
FIELDTYPE_HOLE_DIRECTION47 The user property field type is hole direction.
FIELDTYPE_WELD_TYPE48 The user property field type is weld type.
FIELDTYPE_CHAMFER_TYPE49 The user property field type is chamfer type.
FIELDTYPE_WELDING_SITE50 The user property field type is welding site.
FIELDTYPE_FACTOR51 The user property field type is factor.
FIELDTYPE_PART_NAME52 The user property field type is part name.
FIELDTYPE_BOLT_TYPE53 The user property field type is bolt type.
FIELDTYPE_COMPONENT_NAME54 The user property field type is component name.
FIELDTYPE_REBAR_MESH55 The user property field type is rebar mesh.
FIELDTYPE_USERDEFINED56 The user property field type is user defined.
FIELDTYPE_YES_NO57 The user property field type is yes/no.
FIELDTYPE_COMPONENT_STANDARD_FILE58 The user property field type is component standard file.
FIELDTYPE_REBAR_GRADE59 The user property field type is reinforcement bar grade.
FIELDTYPE_REBAR_RADIUS60 The user property field type is reinforcement bar radius.
FIELDTYPE_REBAR_SIZE61 The user property field type is reinforcement bar size.
FIELDTYPE_HOOK_SHAPE62 The user property field type is reinforcement bar hook shape.
FIELDTYPE_CROSSBAR_POSITION63 The user property field type is reinforcement cross bar position.
FIELDTYPE_REBAR_SPLIT_TARGET64 The user property field type is rebar split target.
FIELDTYPE_REBAR_STAGGER_TYPE65 The user property field type is rebar stagger type.
FIELDTYPE_REBAR_LAPPING_SIDE66 The user property field type is rebar lapping side.
FIELDTYPE_REBAR_LAPPING_OFFSET_DIRECTION67 The user property field type is rebar lapping offset direction.
FIELDTYPE_REBAR_LAPPING_OFFSET_TYPE68 The user property field type is rebar lapping offset type.
FIELDTYPE_DISTANCE_LIST_TOTAL69 The user property field type is distance list total.
FIELDTYPE_REBAR_LENGTH_ADJUSTMENT_TYPE70 The user property field type is rebar length adjustment type.
FIELDTYPE_SHAPE71 The user property field type is shape.
FIELDTYPE_PLAIN_HOLE_TYPE72 The user property field type is plain hole type.
FIELDTYPE_MASS_FLOW73 The user property field type is mass flow.
FIELDTYPE_VOLUME_FLOW74 The user property field type is volume flow.
FIELDTYPE_HEAT_CAPACITY75 The user property field type is heat capacity.
FIELDTYPE_PRESSURE_LOSS76 The user property field type is pressure loss.
FIELDTYPE_VELOCITY77 The user property field type is velocity.
FIELDTYPE_FLOW_COEFFICIENT78 The user property field type is flow coefficient.
FIELDTYPE_DYNAMIC_VISCOSITY79 The user property field type is dynamic viscosity.
FIELDTYPE_KINEMATIC_VISCOSITY80 The user property field type is kinematic viscosity.
FIELDTYPE_POWER81 The user property field type is power.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next