UserDefinedElement Class |
The UserDefinedElement class represents a user-defined attribute specified by its name.
A user-defined element is converted into a textual value before it is drawn.
Inheritance Hierarchy
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The UserDefinedElement type exposes the following members.
Constructors
Name | Description | |
---|---|---|
UserDefinedElement(String) |
Creates a new user-defined element instance with the given name.
| |
UserDefinedElement(String, FontAttributes) |
Creates a new user-defined element instance with the given name and font.
|
Properties
Name | Description | |
---|---|---|
Font |
The font of the user-defined attribute.
| |
Name |
The name of the user-defined attribute.
| |
Unit |
Gets or sets the unit attributes.
| |
Value |
The value of the user-defined attribute.
|
Methods
Name | Description | |
---|---|---|
Clone |
Clones the object.
(Overrides ElementBaseClone.) | |
GetUnformattedString |
Returns the content as a string without formatting.
(Overrides ElementBaseGetUnformattedString.) | |
IsEqual |
Compares the current object with an object of the same type.
(Overrides ElementBaseIsEqual(Object).) |
See Also