![]() | UnitAttributes Class |
The UnitAttributes class handles attributes related to units and formatting of values.

Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63

The UnitAttributes type exposes the following members.

Name | Description | |
---|---|---|
![]() | UnitAttributes |
Creates a new default UnitAttributes attributes instance. The default values are Units.Automatic, FormatTypes.Automatic.
|
![]() | UnitAttributes(Units, FormatTypes) |
Creates a new UnitAttributes attributes instance with the given parameters.
|


Name | Description | |
---|---|---|
![]() | Clone |
Clones the object.
|
![]() | IsEqual |
Compares the current object with an object of the same type.
(Overrides GenericAttributesBaseIsEqual(Object).) |