TextElement Class |
The TextElement class defines a user-defined text in a mark content.
Inheritance Hierarchy
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The TextElement type exposes the following members.
Constructors
Name | Description | |
---|---|---|
TextElement(String) |
Creates a new text element instance with the given textual value.
| |
TextElement(String, FontAttributes) |
Creates a new text element instance with the given textual value and font.
|
Properties
Methods
Name | Description | |
---|---|---|
Clone |
Clones the object.
(Overrides ElementBaseClone.) | |
GetUnformattedString |
Returns the content as a string without formatting.
(Overrides ElementBaseGetUnformattedString.) | |
IsEqual |
Compares the current object with an object of the same type.
(Overrides ElementBaseIsEqual(Object).) |
See Also