Text Class

The Text class defines a drawing object that can hold a text string and is shown in a drawing.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
[SerializableAttribute]
public sealed class Text : DrawingObject, IAxisAlignedBoundingBox, 
	IObjectAlignedBoundingBox, IMovableRelative, IPlacing, IHasChildren, IHideable

The Text type exposes the following members.

Constructors
  NameDescription
Public methodText(ViewBase, Point, String)
Creates a new text instance with the given text string.
Public methodText(ViewBase, Point, String, PlacingBase)
Creates a new text instance with the given text string using a specific placing type.
Public methodText(ViewBase, Point, String, TextTextAttributes)
Creates a new text instance with the given text string and text attributes.
Public methodText(ViewBase, Point, String, PlacingBase, TextTextAttributes)
Creates a new text instance with the given text string and text attributes using a specific placing type.
Top
Properties
  NameDescription
Public propertyAttributes
The attributes for the text.
Public propertyHideable
Accesses the information if this object is hidden or not or if it should be.
Public propertyInsertionPoint
The insertion point of the text.
Public propertyPlacing
The current placing of the object. See the placing types for different placing options.
Public propertyTextString
The contents of the text.
Top
Methods
  NameDescription
Public methodDelete
Deletes the text from the current drawing database.
(Overrides DatabaseObjectDelete.)
Public methodGetAxisAlignedBoundingBox
Returns the axis aligned bounding box of the text (rectangle format).
Public methodGetObjectAlignedBoundingBox
Returns the object aligned bounding box of the text (rectangle format).
Public methodGetObjects
Gets the children objects of the current object.
Public methodGetObjects(Type)
Gets the children objects of the current object that are of certain types.
Public methodInsert
Inserts the text into the current drawing database.
(Overrides DatabaseObjectInsert.)
Public methodIsEqual
Compares the current object with an object of the same type.
(Overrides DrawingObjectIsEqual(Object).)
Public methodModify
Modifies the text in the current drawing database.
(Overrides DatabaseObjectModify.)
Public methodMoveObjectRelative
Moves the object using the move vector.
Public methodSelect
Selects the text from the current drawing database.
(Overrides DatabaseObjectSelect.)
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next