TeklaStructuresSettingsInvalidPathCallback Delegate

The invalid path callback - provides error logging for GetAdvancedOptionPaths when a string is found to be invalid as a path

Namespace:  Tekla.Structures
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public delegate void InvalidPathCallback(
	string advancedOption,
	string invalidString,
	string exceptionMessage
)

Parameters

advancedOption
Type: SystemString
The advanced option name.
invalidString
Type: SystemString
The invalid string.
exceptionMessage
Type: SystemString
The exception message if an exception was thrown when converting the string to a path.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next