TeklaStructuresSettings Class

The TeklaStructuresSettings class provides methods to inquire application settings.
Inheritance Hierarchy
SystemObject
  Tekla.StructuresTeklaStructuresSettings

Namespace:  Tekla.Structures
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
[SerializableAttribute]
public sealed class TeklaStructuresSettings

The TeklaStructuresSettings type exposes the following members.

Constructors
  NameDescription
Public methodTeklaStructuresSettings
Initializes a new instance of the TeklaStructuresSettings class
Top
Methods
  NameDescription
Public methodStatic memberGetAdvancedOption(String, Boolean)
Returns the value of an advanced option variable.
Public methodStatic memberGetAdvancedOption(String, Double)
Returns the value of an advanced option variable.
Public methodStatic memberGetAdvancedOption(String, Int32)
Returns the value of an advanced option variable.
Public methodStatic memberGetAdvancedOption(String, String)
Returns the value of an advanced option variable.
Public methodStatic memberCode exampleGetAdvancedOptionPaths
Gets the value of an advanced option as a list of valid paths. Strings with path separator ; are split into separate paths and any blank paths (containing only white space) are ignored. Paths do not need to exist but must use valid characters and format. Note: All valid paths are returned even when invalid paths are encountered.
Public methodStatic memberGetOptions(ClashCheckOptions)
Returns the value of the clash check options.
Public methodStatic memberGetOptions(ComponentOptions)
Returns the value of the component options.
Public methodStatic memberIsPourEnabled
Determines whether pour management is enabled.
Public methodStatic memberIsToolOptionOn
Determines whether select switch is on.
Public methodStatic memberSetOptions(ClashCheckOptions)
Sets the clash check options.
Public methodStatic memberSetOptions(ComponentOptions)
Sets the component options.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next