Tekla.Structures.Model.Operations Namespace |
The Tekla.Structures.Model.Operations namespace contains functionality related to operations.
Classes
Class | Description | |
---|---|---|
GuidConversion |
Conversion of old TS GUIDs to current GUIDs.
GUIDs are changed in TS save as operation, this class can be used to convert old GUIDs to current GUIDs.
To recognize the need for GUID conversion, application needs to save project GUID and compare to the current project GUID.
Note: With big models the instance uses a lot of memory.
| |
Operation |
The Operation class implements Tekla Structures level operations.
| |
OperationProgressBar |
The ProgressBar class implements progress bar with cancel button.
|
Structures
Structure | Description | |
---|---|---|
OperationIFCExportFlags |
Boolean flags for IFC 4 export.
|
Enumerations
Enumeration | Description | |
---|---|---|
OperationExportBasePoint |
Export base point
| |
OperationIFCExportViewTypeEnum |
View configuration type for IFC export
| |
OperationMISExportTypeEnum | The MIS export types. | |
OperationShapeMetadataResult |
The result type of the shape metadata operations. If you alter this, check if
you need to change ShapeMetadataResult_e on the Tekla Structures core side
| |
OperationUnselectedModeEnum | Specifies what ShowOnlySelected(OperationUnselectedModeEnum) should do to unselected parts. |