Tekla.Structures.Model.Collaboration Namespace |
The Tekla.Structures.Model.Collaboration namespace contains some extra functionality to get information about IFC reference model objects. This functionality is not really a part of the Tekla product model and might change in the near future.
Classes
Class | Description | |
---|---|---|
IFC2X3_ParametricObject_CircleHollowProfile |
The IFC2X3_ParametricObject_CircleHollowProfile class contains the circular and hollow profile definition.
| |
IFC2X3_ParametricObject_CircleProfile |
The IFC2X3_ParametricObject_CircleProfile class contains the circular profile definition.
| |
IFC2X3_ParametricObject_CShapeProfile |
The IFC2X3_ParametricObject_CShapeProfile class contains the C-shape profile definition.
| |
IFC2X3_ParametricObject_EllipseProfile |
The IFC2X3_ParametricObject_EllipseProfile class contains the ellipse profile definition.
| |
IFC2X3_ParametricObject_IShapeProfile |
The IFC2X3_ParametricObject_IShapeProfile class contains the I-shape profile definition.
| |
IFC2X3_ParametricObject_LShapeProfile |
The IFC2X3_ParametricObject_LShapeProfile class contains the L-shape profile definition.
| |
IFC2X3_ParametricObject_RectangleHollowProfile |
The IFC2X3_ParametricObject_RectangleHollowProfile class contains the rectangular and hollow profile definition.
| |
IFC2X3_ParametricObject_RectangleProfile |
The IFC2X3_ParametricObject_RectangleProfile class contains the rectangular profile definition.
| |
IFC2X3_ParametricObject_TShapeProfile |
The IFC2X3_ParametricObject_TShapeProfile class contains the T-shape profile definition.
| |
IFC2X3_ParametricObject_UShapeProfile |
The IFC2X3_ParametricObject_UShapeProfile class contains the U-shape profile definition.
| |
IFC2X3_ParametricObject_ZShapeProfile |
The IFC2X3_ParametricObject_ZShapeProfile class contains the Z-shape profile definition.
| |
ParametricObject_CustomProfile |
The ParametricObject_CustomProfile class contains the custom profile definition.
| |
ParametricObject_ObjectBoundingBox |
The ParametricObject_ObjectBoundingBox class contains the object bounding box (OBB) definition.
| |
ReferenceModelObjectAttribute |
The ReferenceModelObjectAttribute class is a base class from where concrete attributes are derived from. The documentation about
different attributes and their function can be found from the vendor specification, for example from the IFC format specification.
| |
ReferenceModelObjectAttributeEnumerator |
The ReferenceModelObjectAttributeEnumerator class can be used to enumerate through reference model object attributes.
|
Enumerations
Enumeration | Description | |
---|---|---|
ReferenceModelObjectAttributeAttributeTypeEnum |
All the reference model object attribute types.
|