Tekla.Structures.Filtering Namespace |
The Tekla.Structures.Filtering namespace includes the functionality to create Tekla Structures filter files for models and drawings.
Classes
Class | Description | |
---|---|---|
BinaryFilterExpression |
The BinaryFilterExpression class represents a binary expression between two filter expressions.
This class cannot be inherited.
| |
BinaryFilterExpressionCollection |
The BinaryFilterExpressionCollection class represents a collection of BinaryFilterItem objects.
The class is used to represent linear expressions. This class cannot be inherited.
| |
BinaryFilterExpressionItem |
The BinaryFilterExpressionItem class represents a data item in a BinaryFilterExpressionCollection.
This class cannot be inherited.
| |
BooleanConstantFilterExpression |
The BooleanConstantFilterExpression class represents a constant Boolean filter expression.
| |
BooleanFilterExpression |
The BooleanFilterExpression class represents a Boolean filter expression.
| |
DataFilterExpression |
The DataFilterExpression class represents a basic data type for a filter expression.
This is a base class for other filter expressions and cannot be used directly.
| |
DateTimeConstantFilterExpression |
The DateTimeConstantFilterExpression class represents a constant DateTime filter expression.
| |
DateTimeFilterExpression |
The DateTimeFilterExpression class represents a DateTime filter expression.
| |
Expression |
The Expression class represents an expression. This is a base class for other expressions and cannot be used directly.
| |
Filter |
The Filter class creates a filter file based on the input FilterExpression object.
| |
FilterExpression |
The FilterExpression class represents a filter expression. This is a base class for other
filter expressions and should not be used directly.
| |
InvalidFilterExpressionException |
The InvalidFilterExpressionException class represents an error that occurred during the expression evaluation.
This class cannot be inherited.
| |
NumericConstantFilterExpression |
The NumericConstantFilterExpression class represents a constant numeric filter expression.
| |
NumericFilterExpression |
The NumericFilterExpression class represents a numeric filter expression.
| |
StringConstantFilterExpression |
The StringConstantFilterExpression class represents a constant string filter expression.
| |
StringFilterExpression |
The StringFilterExpression class represents a string filter expression.
|
Enumerations
Enumeration | Description | |
---|---|---|
BinaryFilterOperatorType |
The binary filter operator type defines the operators between two binary filters.
| |
BooleanOperatorType |
The Boolean operator type defines the operators between two Boolean filter expressions.
| |
DateTimeOperatorType |
The DateTime operator type defines the operators between two DateTime filter expressions.
| |
FilterExpressionFileType |
The filter expression file type defines the filter expression file types.
| |
InvalidFilterExpressionExceptionReasonsType |
The invalid filter expression exception reasons type defines the possible reasons for the
InvalidFilterExpressionException.
| |
NumericOperatorType |
The numeric operator type defines the operators between two numeric filter expressions.
| |
OperatorType |
The operator type defines the operators between two filter expressions.
| |
StringOperatorType |
The string operator type defines the operators between two string filter expressions.
|