TeklaStructuresFiles Class

The TeklaStructuresFiles class is for the paths where the attributes file will be searched for.
Inheritance Hierarchy
SystemObject
  Tekla.StructuresTeklaStructuresFiles

Namespace:  Tekla.Structures
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public class TeklaStructuresFiles

The TeklaStructuresFiles type exposes the following members.

Constructors
  NameDescription
Public methodTeklaStructuresFiles
Initializes a new instance of the TeklaStructuresFiles class.
Top
Properties
  NameDescription
Public propertyPropertyFileDirectories
The directories where to look for property files.
Top
Methods
  NameDescription
Public methodGetAttributeFile(String)
Gets a file info representing the first match in the standard property file directories.
Public methodGetAttributeFile(ListString, String)
Gets a file info representing the first match in the search directories.
Public methodStatic memberGetFileDictionaryByExtension
Retrieves a dictionary of file names and their corresponding paths from multiple directories.
Public methodGetMultiDirectoryFileList
Gets a list of files with the given extension from the default search directories.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next