Tekla.Structures.Drawing Namespace |
The Tekla.Structures.Drawing namespace includes the functionality to insert, select, modify or delete objects inside a Tekla Structures drawing. The namespace also includes possibilites to query different kind of data from the current drawing instance, such as information about the currently selected objects. The namespace offers the functionality through .NET remoting and the COM interface. See the DrawingHandler class to get started with drawings.
Classes
Class | Description | |
---|---|---|
AlongLineOrWithLeaderLineAndParentObjectAlongPartPlacingType |
The AlongLineOrWithLeaderLineAndParentObjectAlongPartPlacingType class defines
a placing type that places the object using the along line placing as the first option.
If there is no room for the first option the fallback option will be used.
The fallback option is placing the object with a leader line and rotated to be at the
same angle as the connected part.
| |
AlongLineOrWithLeaderLinePlacingType |
The AlongLineOrWithLeaderLinePlacingType class defines a placing type that
places the object using the along line placing as the first option.
If there is no room for the first option the fallback option will be used.
The fallback option is placing the object with a leader line.
| |
AlongLinePlacing |
The AlongLinePlacing class defines a placing where the object is
located and moved along a line defined by two points.
| |
AlongLinePlacingType |
The AlongLinePlacingType class defines a placing type that
places the object using the along line placing.
| |
AlongPartCenteredPlacingType |
The AlongPartCenteredPlacingType class defines a placing type
that places the object using the along line placing.
The line used will be the part's edge in the center of that line.
| |
AngleDimension |
The AngleDimension class defines an angle dimension between two lines. The dimension can be shown
by a triangle or in degrees. You can also enter the triangle base length.
| |
AngleDimensionAttributes |
The AngleDimensionAttributes class contains the attributes for angle dimensions.
| |
Arc |
The Arc class defines an arc that is a two-point line with an optional curve radius.
It can be created using either two points and a radius or three points.
| |
ArcArcAttributes |
The ArcAttributes class is the attributes class for the arc.
| |
ArrowheadAttributes |
The ArrowheadAttributes class handles attributes related to arrowheads of different objects.
| |
AssemblyDrawing |
The AssemblyDrawing class is for handling assembly drawings.
| |
AttributesBase |
The AttributesBase class is the class that all the main attributes that can load attribute files inherit from.
| |
BaseLinePlacing |
The BaseLinePlacing class defines a placing where the
object is placed using a line as a reference.
This will thus define the object's X-axis along that line.
| |
BaseLinePlacingType |
The BaseLinePlacingType class defines a placing type that
places the object using the base line placing.
| |
BaseLineWithArrowAtEndPointPlacingType |
The BaseLineWithArrowAtEndPointPlacingType class defines a
placing type that places the object using the base line placing.
The line is drawn and will have an arrow at the end point.
| |
BaseLineWithArrowAtStartPointPlacingType |
The BaseLineWithArrowAtStartPointPlacingType class defines a
placing type that places the object using the base line placing.
The line is drawn and will have an arrow at the start point.
| |
Bolt |
The Bolt class contains methods related to bolts.
A bolt is a drawing object derived from a model object.
It represents a drawing bolt that has a reference to the
actual bolt in the model database.
| |
BoltBoltAttributes |
The BoltAttributes class is the attributes class for the bolt.
| |
CannotCreateSectionViewFrom3dView |
The CannotCreateSectionViewFrom3dView class defines the exception that is
thrown when a user tries to create a section view from a 3d view.
| |
CannotDeleteActiveDrawingException |
The CannotDeleteActiveDrawingException class defines the exception
that is thrown when a user tries to delete a drawing
that is active.
| |
CannotGetAttributeForPluginDueToIncorrectTypeException |
The CannotGetAttributeForPluginDueToIncorrectTypeException class defines the exception that is
thrown when Plugin.GetAttribute is called but the type is incorrect.
| |
CannotGetAttributeForPluginDueToInexistantFieldException |
The CannotGetAttributeForPluginDueToInexistantFieldException class defines the exception that is
thrown when Plugin.GetAttribute is called but the field does not exist.
| |
CannotGetAttributeForPluginException |
The CannotGetAttributeForPluginException class defines the exception that is
thrown when Plugin.GetAttribute is called but the attribute cannot be fetched.
| |
CannotInsertDrawingException |
The CannotInsertDrawingException class defines the exception
that is thrown when a user tries to insert a drawing
when another drawing is active.
| |
CannotLoadAttributesException |
The CannotLoadAttributesException class defines the exception
that is thrown when the loading of attributes failed.
| |
CannotModifyNonActiveDrawingException |
The CannotModifyNonActiveDrawingException class defines the exception
that is thrown when a user tries to modify a drawing
that is not set as active.
| |
CannotPerformOperationDrawingEditorMustBeClosedException |
The CannotPerformOperationDrawingEditorMustBeClosedException class
defines the exception that is thrown when a user tries to do an
operation which requires the drawing editor to be closed.
| |
CannotPerformOperationDrawingIsActiveException |
The CannotPerformOperationDrawingIsActiveException class defines the
exception that is thrown when a user tries to do an operation which
requires that the drawing is not active.
| |
CannotPerformOperationDrawingMustBeActiveException |
The CannotPerformOperationDrawingMustBeActiveException class defines the
exception that is thrown when a user tries to do an operation which
requires that the drawing is active.
| |
CannotPerformOperationDrawingNotUpToDateException |
The CannotPerformOperationDrawingNotUpToDateException class defines the
exception that is thrown when a user tries to do an operation which
requires that the drawing is active.
| |
CannotPerformOperationNumberingNotUpToDate |
The CannotPerformOperationNumberingNotUpToDate class
defines the exception that is thrown when a user tries to do an
operation which requires that numbering is up to date.
| |
CannotSetAttributeForPluginDueToIncorrectTypeException |
The CannotSetAttributeForPluginDueToIncorrectTypeException class defines the exception that is
thrown when Plugin.SetAttribute is called but the type is incorrect.
| |
CannotSetAttributeForPluginDueToInexistantFieldException |
The CannotSetAttributeForPluginDueToInexistantFieldException class defines the exception that is
thrown when Plugin.SetAttribute is called but the field does not exist.
| |
CannotSetAttributeForPluginException |
The CannotSetAttributeForPluginException class defines the exception that is
thrown when Plugin.SetAttribute is called but the attribute cannot be set.
| |
CastUnitDrawing |
The CastUnitDrawing class is for handling cast unit drawings.
| |
Circle |
The Circle class defines the graphical object circle. A circle can also be hatched.
| |
CircleCircleAttributes |
The CircleAttributes class is the attributes class of the circle.
| |
ClosedGraphicObject |
The ClosedGraphicObject class is an abstract base class for all closed graphic objects
(the circle, the cloud, the polygon and the rectangle).
| |
ClosedGraphicObjectClosedGraphicObjectAttributes |
The ClosedGraphicObjectAttributes class is the attributes class for the closed graphic object.
| |
Cloud |
The Cloud class defines a cloud that is a polygon with a specific size set for the bulges.
| |
CloudCloudAttributes |
The CloudAttributes class is the attributes class for the cloud.
| |
Connection |
The Connection class contains methods related to connections.
A connection is a drawing object derived from a model object.
It represents a drawing connection that has a reference to the
actual connection in the model database.
| |
ContainerElement |
The ContainerElement class defines container elements. A container element
is a mark element that has a frame and contains other mark elements.
A container element may also contain container elements to achieve nested frames.
| |
ContainerView |
The ContainerView class contains container views that contain other drawing objects, including other views and container views. The drawing sheet is a container view.
Container views do not contain drawing representations of model objects.
| |
CurvedDimensionBase |
The CurvedDimensionBase class is the base class for radial and orthogonal curved dimensions.
| |
CurvedDimensionOrthogonal |
The CurvedDimensionOrthogonal class defines a curved dimension with orthogonal reference lines.
| |
CurvedDimensionRadial |
The CurvedDimensionRadial class defines a curved dimension with radial reference points.
The dimension text on the line can be either a distance or an angle value.
| |
CurvedDimensionSetBase |
The CurvedDimensionSetBase class is the base class for curved dimension sets which are defined by
an arc and a point list.
| |
CurvedDimensionSetBaseCurvedDimensionSetBaseAttributes |
The CurvedDimensionSetBaseAttributes class contains the attributes for the curved dimensions.
| |
CurvedDimensionSetHandler |
The CurvedDimensionSetHandler class contains operations for creating curved dimension sets.
| |
CurvedDimensionSetOrthogonal |
The CurvedDimensionSetOrthogonal class defines a curved dimension set with orthogonal reference lines.
| |
CurvedDimensionSetOrthogonalCurvedDimensionSetOrthogonalAttributes |
The CurvedDimensionSetOrthogonalAttributes class contains the attributes for managing all the attributes
of the curved dimension with orthogonal reference lines.
| |
CurvedDimensionSetRadial |
The CurvedDimensionSetRadial class defines a curved dimension set with radial reference lines.
| |
CurvedDimensionSetRadialCurvedDimensionSetRadialAttributes |
The CurvedDimensionSetRadialAttributes class contains the attributes for managing all the attributes
of the curved dimension with radial reference lines.
| |
CurvedSectionMark |
The CurvedSectionMark class defines a drawing object that illustrates a curved section in a specific view.
In contrast to straight section mark, the curved section mark can only be inserted as a result of
creating a curved section view.
| |
CustomLineType |
The CustomLineType class defines the custom line types of the drawing objects.
| |
CustomLineTypeCatalog |
The CustomLineTypeCatalog provides accessors to fetch the possible custom line types of drawing objects.
| |
DatabaseObject |
The DatabaseObject class is a base class for all drawing objects.
| |
DetailMark |
The DetailMark class defines a drawing object that illustrates a detail in a specific view.
| |
DetailMarkDetailMarkAttributes |
The DetailMarkAttributes class is the attributes class for detail marks.
| |
DetailMarkSymbolAttributes |
The DetailMarkSymbolAttributes class is for detail mark attributes related to the shape of
the connecting symbol.
| |
DetailMarkTagsAttributes |
The DetailMarkTagsAttributes class contains attributes for detail mark tags.
| |
DimensionBase |
The DimensionBase class is the common base class for all the different dimensions.
| |
DimensionLink |
The DimensionLink class contains methods related to dimension links.
A dimension link is a link between two dimension sets.
| |
DimensionSetBase |
The DimensionSetBase class is the common base class for all the different dimension sets.
The dimension set base cannot be instantiated.
| |
DimensionSetBaseAttributes |
The DimensionSetBaseAttributes class is the base class for all dimension set attributes.
The class contains attributes that are common to all dimension sets.
| |
DimensionSetBaseAttributesCombinedDimensionAttributes |
The CombinedDimensionAttributes class handles attributes related to
the combination of identical parts of dimensions.
| |
DimensionSetBaseAttributesDimensionExaggerationAttributes |
The DimensionExaggerationAttributes class handles attributes related to
the exaggeration of dimension lines.
| |
DimensionSetBaseAttributesDimensionFormatAttributes |
The DimensionFormatAttributes class controls the precision, format and unit of the dimension.
| |
DimensionSetBaseAttributesDimensionPlacingAttributes |
The DimensionPlacingAttributes class controls the placing of the dimension.
| |
DimensionSetBaseAttributesDimensionTextAttributes |
The DimensionTextAttributes class controls the dimension value representation.
| |
DPMPrinterAttributes |
The DPMPrinterAttributes class contains the attributes for controlling the printing.
| |
Drawing |
The Drawing class represents a drawing in Tekla Structures.
| |
DrawingEnumerator |
The DrawingEnumerator class provides the means to iterate through drawing instances. Drawing enumerators
are generated by the drawing handler.
| |
DrawingEnumeratorBase |
The DrawingEnumeratorBase class is a base class for DrawingObjectEnumerator and DrawingEnumerator.
| |
DrawingHandler |
The DrawingHandler class initializes the interface from a .NET application to Tekla Structures. This object
must be created before any actions can be performed on Tekla Structures drawings.
When this object is created, it is possible to ask the current active
drawing in Tekla Structures, get a list of drawings or create a new drawing.
| |
DrawingLink |
The DrawingLink class defines a drawing link object in a drawing.
When a drawing link is double clicked, the target drawing is opened.
| |
DrawingObject |
The DrawingObject class is an abstract base class for all the objects in the drawing.
All drawing objects have a database identifier and belong to some view.
| |
DrawingObjectNoAttributes |
The NoAttributes class defines attributes for objects that do not contain any attributes.
| |
DrawingObjectEnumerator |
The DrawingObjectEnumerator class provides the means to iterate through drawing object instances. Drawing object enumerators
are generated by the container view and they contain drawing objects that are children of the container view instance.
| |
DwgObject |
The DwgObject class defines a DWG or DXF object that can be inserted into a drawing.
| |
EdgeChamfer |
The EdgeChamfer class contains methods related to edge chamfers.
An edge chamfer is a drawing object derived from a model object.
It represents a drawing chamfer that has a reference to the
actual chamfer in the model database.
| |
EdgeChamferEdgeChamferAttributes |
The EdgeChamferAttributes class is the attributes class for the edge chamfer.
| |
ElementBase |
The ElementBase class is the abstract base class for all mark elements.
| |
EmbeddedObjectAttributes |
The EmbeddedObjectAttributes class contains attributes for embedded objects.
| |
EmbeddedObjectBase |
The EmbeddedObjectBase class defines an embedded object in a drawing.
The object refers to another file in the file system and its drawing
representation is updated when a drawing is opened.
| |
EmbeddedObjectFrame |
The EmbeddedObjectFrame class defines the frame object for embedded objects.
| |
Events |
The Events class allows the user to register event listeners for drawing events.
| |
FontAttributes |
The FontAttributes class contains the basic attributes for fonts.
| |
Frame |
The Frame class defines a frame that can be given to objects, including texts.
A frame is a box around the object. You can specify the color and shape of the box.
| |
GADrawing |
The GADrawing class is for handling general arrangement drawings in Tekla Structures.
| |
GenericAttributesBase |
The GenericAttributesBase class is a base class that shared attributes among many classes use.
| |
GraphicObject |
The GraphicObject class is the abstract base class for all graphic objects
(the arc, the circle, the cloud, the line, the polygon, the polyline and the rectangle).
| |
GraphicObjectGraphicObjectAttributes |
The GraphicObjectAttributes class is the attributes class of the graphic object.
| |
GraphicObjectHatchAttributes |
The GraphicObjectHatchAttributes class contains hatch attributes for graphic object hatches.
| |
Grid |
The Grid class contains methods related to grids.
A drawing grid is inserted/removed using the view.
| |
GridGridAttributes |
The GridAttributes class is the attributes class for the grid.
| |
GridLine |
The GridLine class contains methods related to grid lines.
A drawing grid line is always a child of a grid object.
| |
GridLineGridLabel |
The GridLabel class contains the grid labels of the grid lines, the text label and the insertion points.
| |
GridLineGridLineAttributes |
The GridLineAttributes class is the attributes class for the grid line.
| |
HatchAttributes |
The HatchAttributes base class, inherited by ModelObjectHatchAttributes
and GraphicObjectHatchAttributes, contains hatch attributes.
| |
Hideable |
Accesses the information if this object is hidden or not or if it should be.
| |
HyperLink |
The HyperLink class defines a hyperlink object in a drawing. When a hyperlink is double
clicked, the default browser is launched.
| |
Image |
The Image class defines an image that can be inserted into a drawing.
| |
InsidePartAlongPartOrWithLeaderLinePlacingType |
The InsidePartAlongPartOrWithLeaderLinePlacingType class defines a placing
type that places the object using the base line placing as the first option.
If there is no room for the first option the fallback option will be used.
The fallback option is placing the object with a leader line.
The base line used is in the middle of the part, aligned with the part.
| |
InsidePartAlongPartPlacingType |
The InsidePartAlongPartPlacingType class defines a placing type that
places the object using the base line placing.
The base line used is in the middle of the part, aligned with the part.
| |
InsidePartHorizontalOrWithLeaderLinePlacingType |
The InsidePartHorizontalOrWithLeaderLinePlacingType class defines a placing
type that places the object using the base line placing as the first option.
If there is no room for the first option the fallback option will be used.
The fallback option is placing the object with a leader line.
The base line used is in the middle of the part, aligned with the part.
In addition the object will be rotated to be horizontal in the drawing.
| |
InsidePartHorizontalPlacingType |
The InsidePartHorizontalPlacingType class defines a placing type that
places the object using the base line placing.
The base line used is in the middle of the part, aligned with the part.
In addition the object will be rotated to be horizontal in the drawing.
| |
IntList |
The IntList class defines a type safe list of integers.
| |
InvalidAttributesForOperationException |
The InvalidAttributesForOperationException class defines the exception
that is thrown when an object's attributes are set to something that is
not valid for the object.
| |
InvalidPluginPickerInputException |
The InvalidPluginPickerInputException class defines the exception that is
thrown when UI.Picker is used during a Plugin.Insert call but the previously
assigned PluginPickerInput does not correspond to the next UI.Picker call.
| |
InvalidTypeException |
The InvalidTypeException class defines the exception that is
thrown when a type was not one of the allowed ones.
| |
LayoutAttributes |
The LayoutAttributes class contains attributes for controlling the drawing layout.
| |
LeaderLine |
The LeaderLine class defines a leader line attached to a parent object, for example a Text or a Mark.
The LeaderLine can be modified to add/remove elbow points or to change where it is pointing.
| |
LeaderLineAndParentObjectAlongPartPlacingType |
The LeaderLineAndParentObjectAlongPartPlacingType class defines a placing type that places
the object with a leader line and rotated to be at the same angle as the connected part.
| |
LeaderLinePlacing |
The LeaderLinePlacing class defines a placing where the
object is placed attached to a leader line.
| |
LeaderLinePlacingType |
The LeaderLinePlacingType class defines a placing type that places the object with a leader line.
| |
LevelMark |
The LevelMark class defines a drawing object that is displayed as a level mark in a drawing.
See the Tekla Structures help for more information.
| |
LevelMarkLevelMarkAttributes |
The LevelMarkAttributes class contains the attributes for the level mark.
| |
Line |
The Line class defines a line that is a two-point line with an optional bulge (curve).
| |
LineLineAttributes |
The LineAttributes class is the attributes class of the line.
| |
LineTypeAttributes |
The LineTypeAttributes class contains basic attributes for lines.
| |
LineTypes |
The LineTypes class defines the possible line types that can be used by the drawing objects.
| |
LinkAttributes |
The LinkAttributes class contains the attributes for controlling the appearance of a link.
| |
LinkBase |
The LinkBase class is the base class for links.
| |
LinkFrameAttributes |
The LinkFrameAttributes class contains the attributes for controlling the appearance of
a link frame.
| |
Mark |
The Mark class represents a mark object that contains a single mark.
Several mark objects can be merged into one mark set.
| |
MarkMarkAttributes |
The MarkAttributes class defines the mark attributes.
| |
MarkBase |
The MarkBase class contains general mark information and can be
selected and modified with the general attributes.
| |
MarkBaseMarkBaseAttributes |
The MarkBaseAttributes class is the attributes class for the mark base.
| |
MarkSet |
The MarkSet class defines mark set objects that contain several mark objects merged to one mark set.
| |
MarkSetMarkSetAttributes |
The MarkSetAttributes class is the attribute class for the mark set.
| |
ModelObject |
The ModelObject class is an abstract class for all model objects in the drawing side.
The model objects of the drawing side contain identifiers of the actual model objects in the model database.
The model objects appear and disappear based on current view properties (view size, settings).
| |
ModelObjectHatchAttributes |
The ModelObjectHatchAttributes class contains hatch attributes for model object hatches.
| |
MultiDrawing |
The MultiDrawing class is for handling multidrawings.
| |
NewLineElement |
The NewLineElement class defines a line feed between the desired elements to create multi-row marks.
| |
NormalLineType |
The NormalLineType class defines the non-custom line types that can be used by the drawing objects.
| |
OpenGraphicObject |
The OpenGraphicObject class is an abstract base class for all open graphic objects
(the arc, the line and the polyline).
| |
OpenGraphicObjectOpenGraphicObjectAttributes |
The OpenGraphicObjectAttributes class is the attributes class of the open graphic object.
| |
Part |
The Part class contains methods related to parts.
A part is a drawing object derived from a model object.
It represents a drawing part that has a reference to the
actual part in the model database.
| |
PartPartAttributes |
The PartAttributes class is the attributes class for the part.
| |
PickerInput |
The PickerInput class instances can be provided as predefined results of requests through the
methods of the UI.Picker class.
| |
PickerInputInterrupt |
The PickerInputInterrupt class represents the interruption of picking by the user (e.g. by
pressing Escape while requested to pick points).
Used for values asked by any UI.Picker.Pick* method where an interrupt happens by the user.
| |
PickerInputNPoints |
The PickerInputNPoints class represents a pick of several points in a view.
Used for values asked by UI.Picker.PickPoints(StringList Prompts, out PointList PickedPoints, out ViewBase PickedView) and
UI.Picker.PickPoints(int NumberOfPicks, StringList Prompts, out PointList PickedPoints, out ViewBase PickedView).
| |
PickerInputObject |
The PickerInputObject class represents a pick of an object in a view.
Used for values asked by UI.Picker.PickObject(string Prompt, out DrawingObject PickedObject, out ViewBase PickedView).
| |
PickerInputObjectAndAPoint |
The PickerInputObjectAndAPoint class represents a pick of an object in a view.
It provides both the picked object and the point used to pick the object.
Used for values asked by UI.Picker.PickObject(string Prompt, out DrawingObject PickedObject, out ViewBase PickedView, out Point PickedPoint).
| |
PickerInputPoint |
The PickerInputPoint class represents a pick of one point in a view.
Used for values asked by UI.Picker.PickPoint(string Prompt, out Point PickedPoint, out ViewBase PickedView).
| |
PickerInputPointsWithinAView |
The PickerInputPointsWithinAView class is the base class of PickerInput instances that represent
a pick of one or more points in a view.
| |
PickerInputThreePoints |
The PickerInputThreePoints class represents a pick of three points in a view.
Used for values asked by UI.Picker.PickThreePoints(string FirstPrompt, string SecondPrompt, string ThirdPrompt, out Point FirstPickedPoint, out Point SecondPickedPoint, out Point ThirdPickedPoint, out ViewBase PickedView).
| |
PickerInputTwoPoints |
The PickerInputTwoPoints class represents a pick of two points in a view.
Used for values asked by UI.Picker.PickTwoPoints(string FirstPrompt, string SecondPrompt, out Point FirstPickedPoint, out Point SecondPickedPoint, out ViewBase PickedView).
| |
PickerInputWithinAView |
The PickerInputWithinAView class is the base class of PickerInput instances that represent
a valid pick of point(s) or object(s) in a view.
| |
PickerInterruptedException |
The PickerInterruptedException class defines the exception
that is thrown when a user interrupts the picker.
| |
PlacingAttributes |
The PlacingAttributes class contains the basic attributes for determining an object's placing.
| |
PlacingBase |
The PlacingBase class is the base class for placing types.
If you set a user defined Placing to an object it will override the PreferredPlacingType set in the object's attributes.
Please note that not all objects accept all types.
If you try to use the wrong type it will not be accepted (Insert, Modify will fail).
(It is strongly recommended to use the PreferredPlacingTypes to assign new Placings to objects.)
| |
PlacingDirectionAttributes |
The PlacingDirectionAttributes class contains the basic attributes for placing directions.
| |
PlacingDistanceAttributes |
The PlacingDistanceAttributes class contains the basic attributes for placing distances.
| |
PlacingQuarterAttributes |
The PlacingQuarterAttributes class contains the basic attributes for placing quarters.
| |
PlacingTypes |
The PlacingTypes class defines the different available placing types.
Please note that not all objects accept all types.
If you try to use the wrong type it will not be accepted (Insert, Modify will fail).
| |
Plugin |
The Plugin class represents a drawing plug-in.
| |
PluginPickerInput |
The PluginPickerInput class represents a predefined set of picker inputs that can be provided
to a plug-in object. It replaces the interactive selection of points and/or objects by the user
when the plug-in is inserted into a drawing through the API.
| |
PointList |
The PointList class defines a type safe point list.
| |
PointPlacing |
The PointPlacing class defines a placing where the object is placed at
one point (the insertion point) without any additional placing options.
| |
PointPlacingType |
The PointPlacingType class defines a placing type where the object is placed
at one point (the insertion point) without any additional placing options.
| |
Polygon |
The Polygon class defines a polygon that is a multipoint line which is connected. It can also have a bulge (curved lines).
| |
PolygonPolygonAttributes |
The PolygonAttributes class is the attributes class of the polygon.
| |
Polyline |
The Polyline class defines a polyline that is a multipoint line. It can also have a bulge (curved lines).
| |
PolylinePolylineAttributes |
The PolylineAttributes class is the attributes class of the polyline.
| |
PourBreak |
The PourBreak class contains methods related to pour breaks.
A pour break is a drawing object derived from a model object.
It represents a drawing pour break that has a reference to the
actual pour break in the model database.
| |
PourBreakPourBreakAttributes |
The PourBreakAttributes class is the attributes class for the pour break.
| |
PourObject |
The PourObject class contains methods related to pours.
A pour is a drawing object derived from a model object.
It represents a drawing pour that has a reference to the
actual pour in the model database.
| |
PourObjectPourAttributes |
The PourAttributes class is the attributes class for the pour.
| |
PreferredMarkPlacingTypes |
The PreferredMarkPlacingTypes class contains the available preferred mark placing types.
These are allowed to be used for marks.
However, there are different mark types and not all types can be used by all marks.
If you try to use the wrong type it will not be accepted (Insert, Modify will fail).
| |
PreferredPlacingTypeBase |
The PreferredPlacingTypeBase class is the base class for the preferred placing type.
You can set the PreferredPlacingType in the object's attributes to specify how your object should be placed in the drawing.
Please note that not all objects accept all types.
If you try to use the wrong type it will not be accepted (Insert, Modify will fail).
To use valid types you should use the named defaults
(PreferredTextPlacingTypes for Text, PreferredMarkPlacingTypes for Mark, PreferredSymbolPlacingTypes for Symbol).
| |
PreferredPlacingTypes |
The PreferredPlacingTypes class contains all the available preferred placing types.
Please note that not all objects accept all types.
If you try to use the wrong type it will not be accepted (Insert, Modify will fail).
| |
PreferredSymbolPlacingTypes |
The PreferredSymbolPlacingTypes class contains the available preferred symbol placing types.
These are allowed to be used for symbols.
| |
PreferredTextPlacingTypes |
The PreferredTextPlacingTypes class contains the available preferred text placing types.
These are allowed to be used for texts.
| |
PrintAttributes |
The PrintAttributes class contains the attributes for controlling the printing.
| |
PropertyElement |
The PropertyElement class may represent any of the many different mark element types, such as the profile, the material and the name.
The property is defined by the name and it is converted into a textual value before the mark is drawn.
| |
PropertyElementPropertyElementType |
The PropertyElementType class represents the type of a property element.
| |
PropertyElementPropertyElementTypeBoltMarkPropertyElementTypes |
The BoltMarkPropertyElementTypes class represents the available property element types for bolt marks.
| |
PropertyElementPropertyElementTypeChamferMarkPropertyElementTypes |
The ChamferMarkPropertyElementTypes class represents the available property element types for chamfer marks.
| |
PropertyElementPropertyElementTypeConnectionMarkPropertyElementTypes |
The ConnectionMarkPropertyElementTypes class represents the available property element types for connection marks.
| |
PropertyElementPropertyElementTypeDetailMarkPropertyElementTypes |
The DetailMarkPropertyElementTypes class represents the available property element types for detail marks.
| |
PropertyElementPropertyElementTypeDetailViewLabelMarkPropertyElementTypes |
The DetailViewLabelMarkPropertyElementTypes class represents the available property element types for detail view label marks.
| |
PropertyElementPropertyElementTypeMergedMarkPropertyElementTypes |
The MergedMarkPropertyElementTypes class represents the available property element types for merged marks.
| |
PropertyElementPropertyElementTypePartMarkPropertyElementTypes |
The PartMarkPropertyElementTypes class represents the available property element types for part marks.
| |
PropertyElementPropertyElementTypePourMarkPropertyElementTypes |
The PourMarkPropertyElementTypes class represents the available property element types for pour marks.
| |
PropertyElementPropertyElementTypeReinforcementMarkPropertyElementTypes |
The ReinforcementMarkPropertyElementTypes class represents the available property element types for reinforcement marks.
| |
PropertyElementPropertyElementTypeReinforcementMeshMarkPropertyElementTypes |
The ReinforcementMeshMarkPropertyElementTypes class represents the available property element types for reinforcement mesh marks.
| |
PropertyElementPropertyElementTypeSectionMarkPropertyElementTypes |
The SectionMarkPropertyElementTypes class represents the available property element types for section marks.
| |
PropertyElementPropertyElementTypeSectionViewLabelMarkPropertyElementTypes |
The SectionViewLabelMarkPropertyElementTypes class represents the available property element types for section view label marks.
| |
PropertyElementPropertyElementTypeSurfacingMarkPropertyElementTypes |
The SurfacingMarkPropertyElementTypes class represents the available property element types for surfacing marks.
| |
PropertyElementPropertyElementTypeViewLabelMarkPropertyElementTypes |
The ViewLabelMarkPropertyElementTypes class represents the available property element types for view label marks.
| |
RadiusDimension |
The RadiusDimension class defines a radius dimension that displays the radius of the given arc.
| |
RadiusDimensionAttributes |
The RadiusDimensionAttributes class contains attributes to manage all the attributes of a straight dimension.
| |
Rectangle |
The Rectangle class defines a rectangle that is a box made of four lines with orthogonal angles.
| |
RectangleRectangleAttributes |
The RectangleAttributes class is the attributes class of the rectangle.
| |
RectangleBoundingBox |
The RectangleBoundingBox class represents a bounding box for an object,
i.e. the surrounding box of the object. The bounding box contains the
calculated corner points of the box. The rectangle bounding box is
inherited from the axis-aligned bounding box. The AABB also contains methods
for getting the center point of the box.
| |
ReferenceModel |
The ReferenceModel class represents a reference model object in a drawing.
| |
ReferenceModelReferenceModelAttributes |
The ReferenceModelAttributes class contains attributes for reference model objects.
| |
ReinforcementBase |
The ReinforcementBase class contains methods related to reinforcements.
A reinforcement is a drawing object derived from a model object.
It represents a drawing reinforcement that has a reference to the
actual reinforcement in the model database.
| |
ReinforcementBaseReinforcementBaseAttributes |
The ReinforcementBaseAttributes class is the attributes class for the reinforcement.
| |
ReinforcementBaseReinforcementGroupAttributes |
The ReinforcementGroupAttributes class is the base attributes class for
ReinforcementGroup.
| |
ReinforcementBaseReinforcementMeshAttributes |
The ReinforcementMeshAttributes class is the base attributes class for ReinforcementMesh.
| |
ReinforcementBaseReinforcementSetGroupAttributes |
The ReinforcementSetGroupAttributes class is the base attributes class for
ReinforcementSetGroup.
| |
ReinforcementBaseReinforcementSingleAttributes |
The ReinforcementSingleAttributes class is the base attributes class for
ReinforcementSingle.
| |
ReinforcementBaseReinforcementStrandAttributes |
The ReinforcementStrandAttributes class is the base attributes class for
ReinforcementStrand.
| |
ReinforcementGroup |
The ReinforcementGroup class defines a reinforcement group in the drawing.
| |
ReinforcementMesh |
The ReinforcementMesh class defines a reinforcement mesh in the drawing.
| |
ReinforcementPulloutElement |
The ReinforcementPulloutElement class illustrates the shape and dimensions of a reinforcing bar in a drawing.
| |
ReinforcementSetGroup |
The ReinforcementSetGroup class defines a reinforcement set group in the drawing.
A model rebar set generates one or more groups of rebars for drawing purposes and each group is
represented in a drawing as a reinforcement set group.
ModelIdentifier is always zero for the ReinforcementSetGroup.
| |
ReinforcementSingle |
The ReinforcementSingle class defines a single (as in not part of a group) reinforcement bar in the drawing.
| |
ReinforcementStrand |
The ReinforcementStrand class defines a reinforcement mesh in the drawing.
| |
ReportTemplateElement |
The ReportTemplateElement class represents a template in the Tekla Structures template library.
| |
SectionMark |
The SectionMark class defines a drawing object that illustrates a straight section in a specific view.
| |
SectionMarkBase |
The SectionMarkBase class is a base class for both the SectionMark class and the CurvedSectionMark class.
| |
SectionMarkBaseSectionMarkAttributes |
The SectionMarkAttributes class is the attributes class for section marks.
| |
SectionMarkBaseSectionMarkSymbol |
The SectionMarkSymbol class is for section mark attributes related to the shape of the connecting symbol.
| |
SectionMarkBaseSectionMarkTagAttributes |
The SectionMarkTagAttributes class contains attributes for section mark tags.
| |
SectionMarkBaseSectionMarkTagsAttributes |
The SectionMarkTagsAttributes class contains attributes for section mark tags.
| |
SinglePartDrawing |
The SinglePartDrawing class is for handling single part drawings.
| |
Size |
The Size class contains the width and height properties.
| |
SpaceElement |
The SpaceElement class defines a space between the desired elements.
| |
StraightDimension |
The StraightDimension class defines straight dimensions.
| |
StraightDimensionStraightDimensionAttributes |
The StraightDimensionAttributes class contains the attributes of the straight dimension.
| |
StraightDimensionSet |
The StraightDimensionSet class defines a straight dimension set.
| |
StraightDimensionSetStraightDimensionSetAttributes |
The StraightDimensionSetAttributes class contains the attributes for managing
all the attributes of the straight dimension.
| |
StraightDimensionSetHandler |
The StraightDimensionSetHandler class contains operations for creating and modifying straight dimension sets.
| |
StringList |
The StringList class defines a type safe string collection.
| |
Surfacing |
The Surfacing class contains methods related to surfacings.
A surfacing is a drawing object derived from a model object.
It represents a drawing surfacing that has a reference to the
actual surfacing in the model database.
| |
SurfacingSurfacingAttributes |
The SurfacingAttributes class is the attributes class for the surfacing.
| |
Symbol |
The Symbol class defines a drawing object that is displayed as a symbol in a drawing.
Symbols are located in the environment directory under the folder named "symbols"
in .sym files that can contain up to 255 symbols.
Symbol files can be created with SymEd. See the Tekla Structures help for more information.
| |
SymbolSymbolAttributes |
The SymbolAttributes class contains the attributes for the symbol.
| |
SymbolElement |
The SymbolElement class represents a symbol in the Tekla Structures symbol library.
| |
SymbolInfo |
The SymbolInfo class holds symbol information: the symbol file and the symbol index in the symbol file.
| |
SymbolLibrary |
The SymbolLibrary class is for handling symbol libraries.
| |
TeklaStructuresDrawingsApplicationException |
The TeklaStructuresDrawingsApplicationException class defines the base class for all exceptions
that can be thrown while using Tekla.Structures.Drawing.
| |
TemplateInfo |
The TemplateInfo class holds template information.
| |
Text |
The Text class defines a drawing object that can hold a text string and is shown in a drawing.
| |
TextTextAttributes |
The TextAttributes class is the attributes class for the text.
| |
TextElement |
The TextElement class defines a user-defined text in a mark content.
| |
TextFile |
The TextFile class defines a text file object in a drawing.
| |
TextFileTextFileAttributes |
The TextFileAttributes class contains the attributes for the text file object.
| |
UnitAttributes |
The UnitAttributes class handles attributes related to units and formatting of values.
| |
UserDefinedElement |
The UserDefinedElement class represents a user-defined attribute specified by its name.
A user-defined element is converted into a textual value before it is drawn.
| |
View |
The View class contains methods related to views.
Views are views that contain other drawing objects, excluding other views.
Views also contain drawing representations of model objects.
| |
ViewViewAttributes |
The ViewAttributes class contains the attributes for the view.
| |
ViewViewMarkSymbolAttributes |
The ViewMarkSymbolAttributes class contains symbol attributes for view mark tags.
| |
ViewViewMarkTagAttributes |
The ViewMarkTagAttributes class contains attributes for view mark tags.
| |
ViewViewMarkTagsAttributes |
The ViewMarkTagsAttributes class contains attributes for view mark tags.
| |
ViewViewShorteningAttributes |
The ViewShorteningAttributes class sets the shortening attributes for the view.
If CutParts is set to true, the other values are applied. If it is false, none of the other values matter.
| |
ViewBase |
The ViewBase class is a base class for both the ContainerView class and the View class.
| |
ViewMarkBasicSymbolAttributes |
The ViewMarkBasicSymbolAttributes class contains basic attributes for mark symbols.
| |
ViewMarkBasicTagAttributes |
The ViewMarkBasicTagAttributes class contains basic attributes for view mark tags.
| |
Weld |
The Weld class represents weldings in drawing views that refer to actual welds in the model database.
It has properties and methods to control the graphical representation of welding lines.
Instances of Weld class cannot be inserted with code. These appear in drawings when views are created/updated.
To modify its graphical representation, attributes of Weld class can use .welo setting files.
| |
WeldWeldAttributes |
The WeldAttributes class is the attributes class for the weld.
| |
WeldMark |
The WeldMark class defines a drawing object that illustrates a weld mark in a specific view.
WeldMark class refers to welding marks that appear when creating/updating drawing views. In this case, ModelIdentifier has a value.
WeldMark class also refers to weld marks created with drawing editor UI. In this case, ModelIdentifier value is zero.
Graphical representation of welding marks (line and text properties) can be modified using .wel setting files.
The welding mark settting files (.wls) cannot be used to modify instances of WeldMark class.
| |
WeldMarkSeamVisibilityAttributes |
The SeamVisibilityAttributes class is the attributes class for the weld seam visibility.
| |
WeldMarkWeldMarkAttributes |
The WeldMarkAttributes class is the attributes class for the weld mark attributes.
|
Structures
Structure | Description | |
---|---|---|
TeklaDrawingColor |
The TeklaDrawingColor struct contains a compact storage for drawing color data
This struct is intended to be an "all-in-one" solution for OpenAPI users interacting with drawing colors.
It supports old enums and new user defined RGB colors. The essential principle of this struct is that once
an object of this struct is created (i.e. you have one of these objects instantiated), it contains valid
RGB information, as well as a valid enum value in the case of a standard color. This means users will never
have to run checks to see if their object has a valid RGB value. After all, if they receive this "TrueColor"
object, they expect we can provide them RGB information.
To support this functionality, we need to make sure that there is RGB information present for every single
object of this type that is created. All objects constructed with RGB values are guaranteed to have this,
as well as the ordinary standard drawing colors with values between 0 and 255. Other indices are forbidden,
and will cause an error upon construction attempt. Given that the constructor of this struct can throw an exception,
the struct should never be used as a "middleman", meaning it should never be used to pass color information
from one place to another within the codebase: int color -> TeklaDrawingColor -> int color.
|
Interfaces
Interface | Description | |
---|---|---|
IAxisAlignedBoundingBox |
The IAxisAlignedBoundingBox interface is implemented by objects that have an axis aligned bounding box.
| |
IEvents |
Interface for the Events class allows the user to register event listeners for Drawings events.
This interface allows the Marshaling of the Events class with Trimble.Remoting
| |
IHasChildren |
The IHasChildren interface is implemented by objects that have child objects.
| |
IHideable |
The IHideable interface is used for each object that can be hidden in the drawing.
| |
IIsEqual |
The IIsEqual interface is for comparing objects using the function IsEqual().
| |
IMovableRelative |
The IMovableRelative interface is implemented by objects that can be moved.
| |
IObjectAlignedBoundingBox |
The IObjectAlignedBoundingBox interface is implemented by objects that have an object aligned bounding box.
| |
IPlacing |
The IPlacing interface is for objects that can have different placings.
| |
IPreferredPlacing |
The IPreferredPlacing interface is for objects that can have different preferred placing types.
| |
IRelatedObjects |
The IRelatedObjects interface is implemented by objects that have related objects.
| |
IResizeable |
The IResizeable interface is implemented by objects that can be resized.
|
Delegates
Delegate | Description | |
---|---|---|
EventsDrawingDeletedDelegate |
The delegate to use for drawing deletion.
| |
EventsDrawingInsertedDelegate |
The delegate to use for drawing insertion.
| |
EventsDrawingReadyForIssuingChangeDelegate |
The delegate to use for drawing ready for issuing change event.
| |
EventsDrawingStatusChangedDelegate |
The delegate to use for drawing status change.
| |
EventsDrawingUpdatedDelegate |
The delegate to use for drawing updated (insertion, deletion or modification).
|
Enumerations
Enumeration | Description | |
---|---|---|
AngleTypes |
The different types for angle dimensions.
| |
ArrowheadPositions |
The positions of the arrowheads on the line.
| |
ArrowheadTypes |
The arrowhead types.
| |
AutoSizeOptions |
Options for controlling how the sheet size is
calculated when the SizeDefinitionMode is AutoSize.
| |
BoltRepresentation |
The bolt representations.
| |
CastUnitDrawingCastUnitDrawingCreationType |
Defines the Cast Unit Drawing Creation type.
| |
DetailMarkDetailMarkAttributesDetailBoundaryShape |
The boundary shapes of the detail mark.
| |
DimensionSetBaseAttributesCombineFormats |
The combined dimension formats.
| |
DimensionSetBaseAttributesCurvedDimensionTypes |
The type of the curved dimension.
| |
DimensionSetBaseAttributesDimensionTextPlacings |
The placing types of the dimension value text.
| |
DimensionSetBaseAttributesDimensionTypes |
The dimension types.
| |
DimensionSetBaseAttributesDimensionValueFormats |
The dimension value formats.
| |
DimensionSetBaseAttributesDimensionValuePrecisions |
The value precisions for the dimensions.
| |
DimensionSetBaseAttributesDimensionValueUnits |
The units usable with the dimensions.
| |
DimensionSetBaseAttributesExaggerationDirections |
The direction of the exaggeration.
| |
DimensionSetBaseAttributesExaggerationOrigins |
The origin of the exaggeration.
| |
DimensionSetBaseAttributesExtensionLineTypes |
The extension line types.
| |
DimensionSetBaseAttributesFrameTypes |
The frame types around the dimension values.
| |
DimensionSetBaseAttributesPlacings |
The placing types of the objects.
| |
DimensionSetBaseAttributesShortDimensionTypes |
The position of the short dimension value.
| |
DotPrintAreaType |
The print area type.
| |
DotPrintColor |
Output color mode.
| |
DotPrintOrientationType |
The print orientation type.
| |
DotPrintOutputType |
The printer output type.
| |
DotPrintPaperSize |
The paper size.
| |
DotPrintScalingType |
The print scaling type.
| |
DotPrintToMultipleSheet |
The print to multiple sheet type.
| |
DrawingColors |
The colors used in Tekla.Structures.Drawing.
| |
DrawingHandlerMessageExecutionModeEnum |
The message execution modes of Tekla Structures.
| |
DrawingHatchColors |
The hatch colors used in Tekla.Structures.Drawing.
| |
DrawingUpToDateStatus |
The drawing up to date status.
| |
EmbeddedObjectScalingOptions |
The options for controlling the scaling of the objects in the drawing.
| |
EventsDrawingUpdateTypeEnum |
The types of drawing update event.
| |
FormatTypes |
The available format types.
| |
FrameTypes |
The available frame styles around the object.
| |
HideableHiddenFlags |
The flag for keeping track of objects hidden status.
| |
HideableShouldBeHiddenFlags |
The flag for keeping track if object should be hidden.
| |
IncludeRevisionMarkEnum |
Options for including a revision info in file name
| |
LeaderLineLeaderLineTypes |
The different types of leader lines available.
| |
LevelMarkLevelMarkType |
Defines options about how the level mark is shown.
| |
LineTypesEnum |
The line types (the presentation of the line).
| |
MarkBaseMarkBaseAttributesTextAlignOptions |
Enumeration of the possible text alignment values.
| |
MarkSymbolShape |
The mark symbol shapes for the detail mark.
| |
PartRepresentation |
The part representations.
| |
ReinforcementBaseHookedEndSymbolTypes |
The available hooked end symbol types.
See Tekla Structures help, "Reinforcement appearance", for more information.
| |
ReinforcementBaseReinforcementRepresentationTypes |
The available reinforcement representation types.
See Tekla Structures help, "Reinforcement appearance", for more information.
| |
ReinforcementBaseReinforcementVisibilityTypes |
The available reinforcement visibility types.
Only applies to bar groups and meshes.
See Tekla Structures help, "Setting the visibility of reinforcement in drawings", for more information.
| |
ReinforcementBaseStraightEndSymbolTypes |
The available straight end symbol types.
See Tekla Structures help, "Reinforcement appearance", for more information.
| |
ReinforcementPulloutElementEndSymbols |
The shape of the bar ends in the pull-out.
| |
ReinforcementPulloutElementRotation |
The rotation of the pull-out.
| |
ScalingOptions |
The options for controlling the scaling of the objects in the drawing.
| |
SectionMarkBaseSectionMarkSymbolSymbolShapes |
The possible shapes of the section mark symbol.
| |
SectionMarkBaseSectionMarkTagAttributesTagShowOnSide |
The values that determine on which side(s) the mark tag text is shown.
| |
SectionMarkBaseSectionMarkTagAttributesTagTextRotation |
The mark tag text rotation values.
| |
SizeDefinitionMode |
Controls the size definition mode of the drawing sheet. Set the mode to
SizeDefinitionMode.SpecifiedSize if you want to force the sheet to a
certain size.
| |
SurfacingRepresentation |
The surfacing representations.
| |
TagLocation |
The mark tag location values.
| |
TextAlignment |
The alignment of the text.
| |
Units |
The available unit types.
| |
ViewHorizontalLabelPosition |
The horizontal label position types.
| |
ViewLabelLineLengthType |
The label line length types.
| |
ViewShorteningCutPartType |
The vertical label position types.
| |
ViewVerticalLabelPosition |
The vertical label position types.
| |
ViewViewTypes |
The possible types of views.
| |
WeldRepresentation |
The weld representations.
|