Tekla.Structures.Dialog.UIControls Namespace |
Class | Description | |
---|---|---|
BindableRadioButton |
The BindableRadioButton class represents a RadioButton control that can be bound to the dialog attributes file.
Use "Checked" as the BindPropertyName and "Integer" as the AttributeTypeName.
| |
BoltCatalogSize |
The BoltCatalogSize class represents a control to select the bolt size
using the bolt catalog.
Bolt catalog controls always need to be in pairs, meaning in every dialog there has to be a BoltCatalogStandard and a BoltCatalogSize control. The property BoltCatalogStandard.LinkedBoltCatalogSize sets to which BoltCatalogSize the control is linked. | |
BoltCatalogStandard |
The BoltCatalogStandard class represents a control to select the bolt standard
using the bolt catalog.
Bolt catalog controls always need to be in pairs, meaning in every dialog there has to be a BoltCatalogStandard and a BoltCatalogSize control. The property BoltCatalogStandard.LinkedBoltCatalogSize sets to which BoltCatalogSize the control is linked. | |
CommitAction |
The CommitAction class represents a "template" dialog for commit actions.
| |
ComponentCatalog |
The ComponentCatalog class represents a group of controls to select components
using the component catalog.
| |
CreateApplyCancel |
The CreateApplyCancel class represents a control including the Create-Apply-Cancel button group.
| |
CreateDialog |
The CreateDialog class represents a "template" dialog for creating something from parts.
| |
CustomObservableCollectionT |
CustomObservableCollection for synchronizing UI controls.
| |
DataGrid |
The DataGrid class represents a data grid control that can contain images.
| |
EnvironmentFiles |
The EnvironmentFiles class is for the paths where the attributes file will be searched for.
| |
EnvironmentVariables |
The EnvironmentVariables class contains a sorted list specializing in getting active
environment variables and advanced option settings. It also checks options.ini files
in the active model folder as well as options_user.ini files.
| |
ImageComboBox | Obsolete.
The ImageComboBox class represents a combo box control that can contain images.
| |
ImageItem |
The ImageItem class defines the images that will be contained in the image combo box.
| |
ImageList |
The ImageList class contains a list of ImageItems.
| |
ImageListComboBox |
The ImageListComboBox class represents a combo box control that can contain images from an ImageList control.
| |
LoadingForm |
The LoadingForm class creates a dialog that is shown while something is
being loaded by the main window and that needs the process to finish.
| |
LocalizeForm |
The LocalizeForm class is for localizing the forms.
| |
MaterialCatalog |
The MaterialCatalog class represents a group of controls to select materials
using the material catalog.
| |
MaterialSelectionForm |
The MaterialSelectionForm class represents a dialog to select materials
using the material catalogs.
| |
MeshCatalog |
The MeshCatalog class represents a group of controls to select meshes
using the mesh catalogs.
| |
MeshSelectionForm |
The MeshSelectionForm class represents a dialog to select meshes
using the mesh catalog.
| |
ModelAccess |
The ModelAccess class contains helper methods for connecting to and accessing the model and objects in the model.
The class attempts to provide efficient but robust methods for connecting to and verifying the connection to the model.
| |
OkApplyCancel |
The OkApplyCancel class represents a control including the Ok-Apply-Cancel button group.
| |
OkApplyModifyGetOnOffCancel |
The OkApplyModifyGetOnOffCancel class represents a control including the Ok-Apply-Modify-Get-On/Off-Cancel button group.
| |
OkCancel |
The OkCancel class represents a control including the Ok-Cancel button group.
| |
OrganizerDialog |
The OrganizerDialog class represents a "template" of an organizer dialog.
| |
ProfileCatalog |
The ProfileCatalog class represents a group of controls to select profiles
using the profile catalogs.
| |
ProfileSelectionForm |
The ProfileSelectionForm class represents a dialog to select profiles
using the profile catalogs.
| |
PropertiesDialog |
The PropertiesDialog class represents a "template" of a properties dialog.
| |
ReinforcementCatalog |
The ReinforcementCatalog class represents a group of controls to select rebars
using the rebar catalogs.
| |
ReinforcementSelectionForm |
The ReinforcementSelectionForm class represents a dialog to select rebars
using the rebar catalogs.
| |
SaveLoad |
The SaveLoad class represents a save-load-save as group of controls including the functionality.
| |
ShapeCatalog |
The ShapeCatalog class represents a group of controls to select Shapes
using the Shape catalog.
| |
ShapeSelectionForm |
The ShapeSelectionForm class represents a dialog to select Shapes
using the Shape catalogs.
| |
Tree |
The Tree class represents a tree view control that can contain images.
| |
TreeViewDialog |
The TreeViewDialog class represents a "template" of a tree view dialog.
| |
WpfBoltCatalogSize |
The WPFBoltCatalogSize class represents a control to select the bolt size
using the bolt catalog.
Bolt catalog controls always need to be in pairs, meaning in every dialog there has to be a WpfBoltCatalogStandard and a WpfBoltCatalogSize control. | |
WpfBoltCatalogStandard |
The WpfBoltCatalogStandard class represents a control to select the bolt standard
using the bolt catalog.
Bolt catalog controls always need to be in pairs, meaning in every dialog there has to be a WpfBoltCatalogStandard and a WpfBoltCatalogSize control. | |
WpfComponentCatalog |
The WpfComponentCatalog class represents a group of controls to select components
using the component catalog.
| |
WpfCreateApplyCancel |
Interaction logic for WPFCreateAppyCancel.xaml.
Control is meant to be used with non-dependent plug-ins
| |
WpfFilterCheckBox |
The WpfFilterAttribute class represents a checkbox control for enabling/disabling
dialog attributes defined with StructuresFieldAttribute.
| |
WpfMaterialCatalog |
The WpfMaterialCatalog class represents a group of controls to select materials
using the material catalog.
| |
WpfMeshCatalog |
The WpfMeshCatalog class represents a group of controls to select meshes
using the mesh catalog.
| |
WpfOkApplyModifyGetOnOffCancel |
Interaction logic for WpfOkApplyModifyGetOnOffCancel.xaml
| |
WpfOkCreateCancel |
Interaction logic for WPFOkCreateCancel.xaml
| |
WpfProfileCatalog |
The WpfProfileCatalog class represents a group of controls to select profiles
using the profile catalog.
| |
WpfReinforcementCatalog |
The WpfReinforcementCatalog class represents a group of controls to select rebars
using the reinforcement catalog.
| |
WpfSaveLoad |
Interaction logic for WpfSaveload.xaml
| |
WpfShapeCatalog |
The WpfShapeCatalog class represents a group of controls to select shapes
using the shape catalog.
|
Enumeration | Description | |
---|---|---|
SaveLoadHelpFileTypeEnum |
The help file types.
| |
WpfSaveLoadHelpFileTypeEnum |
The help file types.
|