Tekla.Structures.Dialog Namespace |
The Tekla.Structures.Dialog namespace contains classes and methods that enable for example dialog creation for Tekla Structures plug-ins and localization of dialogs.
Classes
Class | Description | |
---|---|---|
ApplicationFormBase |
The ApplicationFormBase class is the base class for all Tekla Structures dialogs.
The class provides localization, unit conversion and data storage
(temporary and file-based) among other things.
| |
ApplicationWindowBase |
The ApplicationWindowBase class is the base class for all Tekla Structures WPF dialogs.
The class provides localization, unit conversion and data storage
(temporary and file-based) among other things.
| |
AttributeTypeNameEditor |
The AttributeTypeNameEditor class provides a user interface for selecting a type for the bound attribute.
| |
BindPropertyNameEditor |
The BindPropertyNameEditor class provides a user interface for selecting a property for the attribute binding.
| |
Dialogs |
The Dialogs class contains interface methods for Tekla Structures to handle FormBase and WindowBase dialogs.
| |
ErrorDialog |
The ErrorDialog class represents the common error dialog for the Open API.
| |
FormBase |
The FormBase class is the base class for all Tekla Structures dialogs.
The class provides localization, unit conversion and data storage
(temporary and file-based) among other things.
| |
FormBorders |
The FormBorders class handles the storing and restoring of the form size and location.
| |
HelpViewer |
Class for viewing help files with Tekla Structures HelpViewer.exe.
| |
Localization |
The Localization class is for translating strings in .NET dialogs.
| |
LocalizationUtil |
The Util class contains general localizers for different kinds of controls.
| |
LocalizationUtilPropertyLocalizer |
The PropertyLocalizer class localizes properties.
| |
LocExtension |
Localization binding for strings referred in xaml
| |
MainWindow |
The MainWindow class is a class for binding the .NET dialogs under the Tekla Structures main window.
| |
PluginFormBase |
The PluginFormBase class is the base class for plug-in dialogs. The class extends
the FormBase class by adding communications with Tekla Structures.
| |
PluginWindowBase |
The PluginWindowBase class is the base class for plug-in WPF dialogs. The class extends
the WindowBase class by adding communications with Tekla Structures.
| |
ProfileConversion |
The ProfileConversion class provides functionalities to convert profile strings from/to current units (set in
"Units and decimals, Catalog, Profiles, Section Dimension" options).
| |
StructuresDialogArrayAttribute |
The StructuresDialogArrayAttribute class specifies the attribute name for which the attributed
interface will be used as a list item definition. The attributed interface is used to define the
structure of the DataGridView items. In other words it defines all the possible DataGridView
columns. The interface is bound to the DataGridView by referencing the interface's attribute name
from the DataGridView's Tag property.
| |
StructuresDialogAttribute |
The StructuresDialogAttribute class specifies the attribute name to which the value of the
property will be bound in Tekla Structures.
| |
StructuresDialogFilterAttribute |
The StructuresDialogFilterAttribute class specifies the attribute name for which the
value of the attributed property will be used as a filter in Tekla Structures. The return
type of the attributed property must be boolean. The apply and modify operations will only
commit/update those attributes which either do not have a filter property defined or the
value of the filter property is true.
| |
StructuresExtender |
The StructuresExtender class is for binding controls to datatypes. The bindings are
needed to transfer the dialog values to Tekla Structures and onwards to plug-ins.
| |
StructuresInstallation |
Utility functions.
| |
TeklaProgressBar | The TeklaProgressBar class represents the common progress bar control for the Open API. | |
WindowBase |
The WindowBase class is the base class for all Tekla Structures WPF dialogs.
The class provides localization, unit conversion and data storage
(temporary and file-based) among other things.
|
Delegates
Delegate | Description | |
---|---|---|
LocalizationLocalizationCallback |
A delegate for localization functions for different control types.
|
Enumerations
Enumeration | Description | |
---|---|---|
dotdiaUnitTypes_e |
Specifies the Tekla Structures unit types.
| |
ErrorDialogSeverity |
The severity of the message to be displayed.
|