Task Class

The Task class defines a single building site task. It may contain parts, assemblies or other tasks. Tasks may have a hierarchy between them i.e. there are other tasks as subtasks for a parent task. Tasks may also depend on each other, have resources assigned to them or have a single worktype.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
[SerializableAttribute]
public sealed class Task : ModelObject

The Task type exposes the following members.

Constructors
  NameDescription
Public methodCode exampleTask
Creates a new task instance.
Public methodCode exampleTask(Identifier)
Creates a task instance with a known identifier. Select the task after the creation.
Top
Properties
  NameDescription
Public propertyActualEndDate
The actual end date of the task.
Public propertyActualStartDate
The actual start date of the task.
Public propertyActualWorkAmount
The amount of work already used for the task.
Public propertyCompleteness
The percentage of the completeness of the task on the scale from 0 to 100.
Public propertyCritical
The criticality of the task.
Public propertyDescription
A short textual description of the task.
Public propertyLocal
The locality indicates if the task was created in Tekla Structures and Task Manager or imported.
Public propertyName
The name of the task.
Public propertyPlannedEndDate
The planned end date of the task.
Public propertyPlannedStartDate
The planned start date of the task.
Public propertyPlannedWorkAmount
The amount of work planned to be used for the task.
Public propertyScenario
The scenario which the task belongs to.
Public propertyUrl
A link to material or data related to the task. The link can be a hyperlink or a file system link.
Top
Methods
  NameDescription
Public methodCode exampleAddObjectsToTask
Adds objects to the task.
Public methodDelete
Deletes the task instance from the model. The identifier must be set.
(Overrides ModelObjectDelete.)
Public methodStatic memberGetAllTasksOfSelectedObjects
Returns an enumerator of all the tasks related to the selected objects.
Public methodGetDependencies
Returns an enumerator of all the task dependency objects where the task is involved.
Public methodGetFathers
Returns an enumerator of all the task type fathers for the task object.
Public methodInsert
Inserts the task instance in the model.
(Overrides ModelObjectInsert.)
Public methodModify
Modifies the task instance in the model. The identifier must be set.
(Overrides ModelObjectModify.)
Public methodCode exampleRemoveObjectsFromTask
Removes objects from the task.
Public methodSelect
Selects the task instance from the model. The identifier must be set.
(Overrides ModelObjectSelect.)
Top
Examples
The following example creates and inserts a task with two beams as objects into the model. The task has also a scenario:
using System.Collections.Generic;
using System.Collections;
using System;
using Tekla.Structures.Model;
using Tekla.Structures.Geometry3d;

public class Example
{
       public void Example1()
       {
           Point Point1 = new Point(0, 0, 0);
           Point Point2 = new Point(1000, 0, 0);
           Point Point3 = new Point(0, 1000, 0);
           Point Point4 = new Point(1000, 1000, 0);

           Beam Beam1 = new Beam(Point1, Point2);
           Beam Beam2 = new Beam(Point3, Point4);
           Beam1.Profile.ProfileString = "HEA400";
           Beam1.Finish = "PAINT";
           Beam1.Material.MaterialString = "S235JR";
           Beam2.Profile.ProfileString = "HEA400";
           Beam2.Finish = "PAINT";
           Beam2.Material.MaterialString = "S235JR";

           Beam1.Insert();
           Beam2.Insert();

           // The Task
           Task Task1 = new Task();
           Task1.PlannedStartDate = DateTime.Now;
           Task1.Name = "Test Task";
           Task1.Critical = true;
           Task1.Description = "Test task description";
           Task1.Url = "http://test.task.url";

           // Scenario
           HierarchicDefinition ScenarioDefinition = new HierarchicDefinition();
           ScenarioDefinition.Name = "Scenario type";
           ScenarioDefinition.HierarchyType = HierarchicDefinitionTypeEnum.DOT_HIERARCHIC_TASK_SCENARIO;
           ScenarioDefinition.Insert();

           HierarchicObject Scenario = new HierarchicObject();
           Scenario.Name = "Current scenario";
           Scenario.Definition = ScenarioDefinition;
           Scenario.Insert();

           Task1.Scenario = Scenario;

           ArrayList ModelObjects = new ArrayList();
           ModelObjects.Add(Beam1);
           ModelObjects.Add(Beam2);
           Task1.AddObjectsToTask(ModelObjects);

           Task1.Insert();
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next