Task Class

The Task class defines a single building site task. It may contain parts, assemblies or other tasks. Tasks may have a hierarchy between them i.e. there are other tasks as subtasks for a parent task. Tasks may also depend on each other, have resources assigned to them or have a single worktype.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
[SerializableAttribute]
public sealed class Task : ModelObject

The Task type exposes the following members.

Constructors
  NameDescription
Public methodCode exampleTask
Creates a new task instance.
Public methodCode exampleTask(Identifier)
Creates a task instance with a known identifier. Select the task after the creation.
Top
Properties
  NameDescription
Public propertyActualEndDate
The actual end date of the task.
Public propertyActualStartDate
The actual start date of the task.
Public propertyActualWorkAmount
The amount of work already used for the task.
Public propertyCompleteness
The percentage of the completeness of the task on the scale from 0 to 100.
Public propertyCritical
The criticality of the task.
Public propertyDescription
A short textual description of the task.
Public propertyIdentifier
The identifier of the object.
(Inherited from Object.)
Public propertyIsUpToDate
Gets if the object does not have a modification which is not shared.
(Inherited from ModelObject.)
Public propertyLocal
The locality indicates if the task was created in Tekla Structures and Task Manager or imported.
Public propertyModificationTime
Gets latest time of the object was modified or created.
(Inherited from ModelObject.)
Public propertyName
The name of the task.
Public propertyPlannedEndDate
The planned end date of the task.
Public propertyPlannedStartDate
The planned start date of the task.
Public propertyPlannedWorkAmount
The amount of work planned to be used for the task.
Public propertyScenario
The scenario which the task belongs to.
Public propertyUrl
A link to material or data related to the task. The link can be a hyperlink or a file system link.
Top
Methods
  NameDescription
Public methodCode exampleAddObjectsToTask
Adds objects to the task.
Public methodCompareTo
Compares Identifiers of model objects.
(Inherited from ModelObject.)
Public methodDelete
Deletes the task instance from the model. The identifier must be set.
(Overrides ModelObjectDelete.)
Public methodEquals
Check if Identifiers of model objects are same.
(Inherited from ModelObject.)
Public methodCode exampleGetAllReportProperties
Retrieves all properties for the model object in one hashtable. Type for the returned value must be checked using type casting.
(Inherited from ModelObject.)
Public methodStatic memberGetAllTasksOfSelectedObjects
Returns an enumerator of all the tasks related to the selected objects.
Public methodGetAllUserProperties
Retrieves all properties for the model object in one hashtable. Type for the returned value must be checked using type casting.
(Inherited from ModelObject.)
Public methodGetChildren
Returns an enumerator of all the children model objects.
(Inherited from ModelObject.)
Public methodGetCoordinateSystem
Returns the coordinate system for the given model object.
(Inherited from ModelObject.)
Public methodGetDependencies
Returns an enumerator of all the task dependency objects where the task is involved.
Public methodGetDoubleReportProperties
Retrieves multiple double report properties for the model object. It is faster to fetch multiple properties at once.
(Inherited from ModelObject.)
Public methodGetDoubleUserProperties
Retrieves all double properties for the model object.
(Inherited from ModelObject.)
Public methodGetDynamicStringProperty
Gets a dynamic string property from the model object.
(Inherited from ModelObject.)
Public methodGetFatherComponent
Returns the father component of the model object.
(Inherited from ModelObject.)
Public methodGetFathers
Returns an enumerator of all the task type fathers for the task object.
Public methodGetHierarchicObjects
Returns an enumerator of all the connected hierarchic objects.
(Inherited from ModelObject.)
Public methodGetIntegerReportProperties
Retrieves multiple integer report properties for the model object. It is faster to fetch multiple properties at once.
(Inherited from ModelObject.)
Public methodGetIntegerUserProperties
Retrieves all integer properties for the model object.
(Inherited from ModelObject.)
Public methodGetPhase
Retrieves the phase of the model object (the phase number, the phase name, the phase comment and whether the phase is the current one or not).
(Inherited from ModelObject.)
Public methodGetReportProperty(String, Double)
Retrieves a double property of the report for the model object.
(Inherited from ModelObject.)
Public methodGetReportProperty(String, Int32)
Retrieves an integer property of the report for the model object.
(Inherited from ModelObject.)
Public methodGetReportProperty(String, String)
Retrieves a string property of the report for the model object.
(Inherited from ModelObject.)
Public methodGetStringReportProperties
Retrieves multiple string report properties for the model object. It is faster to fetch multiple properties at once.
(Inherited from ModelObject.)
Public methodGetStringUserProperties
Retrieves all string properties for the model object.
(Inherited from ModelObject.)
Public methodGetUserProperty(String, Double)
Retrieves a double property for the model object.
(Inherited from ModelObject.)
Public methodGetUserProperty(String, Int32)
Retrieves an integer property for the model object.
(Inherited from ModelObject.)
Public methodGetUserProperty(String, String)
Retrieves a string property for the model object.
(Inherited from ModelObject.)
Public methodInsert
Inserts the task instance in the model.
(Overrides ModelObjectInsert.)
Public methodModify
Modifies the task instance in the model. The identifier must be set.
(Overrides ModelObjectModify.)
Public methodCode exampleRemoveObjectsFromTask
Removes objects from the task.
Public methodSelect
Selects the task instance from the model. The identifier must be set.
(Overrides ModelObjectSelect.)
Public methodSetDynamicStringProperty
Sets a dynamic string property for the model object.
(Inherited from ModelObject.)
Public methodSetLabel
Sets a label for an object when a new instance is created, this method must be called before Insert. The label is used in plug-ins for identifying the changed object in modification.
(Inherited from ModelObject.)
Public methodSetPhase
Sets the phase of the model object.
(Inherited from ModelObject.)
Public methodSetUserProperties
Sets multiple properties for the model object.
(Inherited from ModelObject.)
Public methodSetUserProperty(String, Double)
Sets a double property for the model object.
(Inherited from ModelObject.)
Public methodSetUserProperty(String, Int32)
Sets an integer property for the model object.
(Inherited from ModelObject.)
Public methodSetUserProperty(String, String)
Sets a string property for the model object.
(Inherited from ModelObject.)
Top
Examples
The following example creates and inserts a task with two beams as objects into the model. The task has also a scenario:
using System.Collections.Generic;
using System.Collections;
using System;
using Tekla.Structures.Model;
using Tekla.Structures.Geometry3d;

public class Example
{
       public void Example1()
       {
           Point Point1 = new Point(0, 0, 0);
           Point Point2 = new Point(1000, 0, 0);
           Point Point3 = new Point(0, 1000, 0);
           Point Point4 = new Point(1000, 1000, 0);

           Beam Beam1 = new Beam(Point1, Point2);
           Beam Beam2 = new Beam(Point3, Point4);
           Beam1.Profile.ProfileString = "HEA400";
           Beam1.Finish = "PAINT";
           Beam1.Material.MaterialString = "S235JR";
           Beam2.Profile.ProfileString = "HEA400";
           Beam2.Finish = "PAINT";
           Beam2.Material.MaterialString = "S235JR";

           Beam1.Insert();
           Beam2.Insert();

           // The Task
           Task Task1 = new Task();
           Task1.PlannedStartDate = DateTime.Now;
           Task1.Name = "Test Task";
           Task1.Critical = true;
           Task1.Description = "Test task description";
           Task1.Url = "http://test.task.url";

           // Scenario
           HierarchicDefinition ScenarioDefinition = new HierarchicDefinition();
           ScenarioDefinition.Name = "Scenario type";
           ScenarioDefinition.HierarchyType = HierarchicDefinitionTypeEnum.DOT_HIERARCHIC_TASK_SCENARIO;
           ScenarioDefinition.Insert();

           HierarchicObject Scenario = new HierarchicObject();
           Scenario.Name = "Current scenario";
           Scenario.Definition = ScenarioDefinition;
           Scenario.Insert();

           Task1.Scenario = Scenario;

           ArrayList ModelObjects = new ArrayList();
           ModelObjects.Add(Beam1);
           ModelObjects.Add(Beam2);
           Task1.AddObjectsToTask(ModelObjects);

           Task1.Insert();
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next