ModelHistoryTakeModifications Method (String, IEnumerableModelObjectModelObjectEnum, ModificationStamp) |
Take modifications since previous call, with object type filtering.
Namespace: Tekla.Structures.Model.History
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public static ModificationInfo TakeModifications( string Name, IEnumerable<ModelObjectModelObjectEnum> ObjectTypes, ModificationStamp PrevStamp = null )
Parameters
- Name
- Type: SystemString
Name of reference which is used for collecting modifications and which is updated. Intended use is to assign an unique name for each client application which needs to be informed of the model updates. Maximum length is 79 characters. - ObjectTypes
- Type: System.Collections.GenericIEnumerableModelObjectModelObjectEnum
Types of object to select. Empty or null selects all types. - PrevStamp (Optional)
- Type: Tekla.Structures.Model.HistoryModificationStamp
When specified, default value of reference if is it not found
Return Value
Type: ModificationInfoAll modifications which happened since the last call. See ModificationInfo reference
Remarks
Same as TakeModifications(String, ModificationStamp), but returns only the types listed in ObjectTypes.
Note that since this function also sets base for the next invocation of for ALL objects,
so using it discards change information for filtered objects.
TakeModifications()
See Also