Symbol Class |
The Symbol class defines a drawing object that is displayed as a symbol in a drawing.
Symbols are located in the environment directory under the folder named "symbols"
in .sym files that can contain up to 255 symbols.
Symbol files can be created with SymEd. See the Tekla Structures help for more information.
Inheritance Hierarchy
SystemObject
Tekla.Structures.DrawingDatabaseObject
Tekla.Structures.DrawingDrawingObject
Tekla.Structures.DrawingSymbol
Tekla.Structures.DrawingDatabaseObject
Tekla.Structures.DrawingDrawingObject
Tekla.Structures.DrawingSymbol
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The Symbol type exposes the following members.
Constructors
Name | Description | |
---|---|---|
Symbol(ViewBase, Point) |
Creates a new symbol instance using the default symbol information and standard attributes.
| |
Symbol(ViewBase, Point, PlacingBase) |
Creates a new symbol instance using the default symbol information, standard attributes and the given placing.
| |
Symbol(ViewBase, Point, SymbolInfo) |
Creates a new symbol instance using standard attributes.
| |
Symbol(ViewBase, Point, SymbolInfo, PlacingBase) |
Creates a new symbol instance using standard attributes.
| |
Symbol(ViewBase, Point, SymbolInfo, SymbolSymbolAttributes) |
Creates a new symbol instance using the given attributes.
| |
Symbol(ViewBase, Point, SymbolInfo, SymbolSymbolAttributes, PlacingBase) |
Creates a new symbol instance using the given attributes and placing.
|
Properties
Name | Description | |
---|---|---|
Attributes |
Gets or sets the symbol attributes.
| |
Hideable |
Accesses the information if this object is hidden or not or if it should be.
| |
InsertionPoint |
Gets or sets the symbol insertion point.
| |
Placing |
The current placing of the object.
See the placing types for different placing options.
| |
QueryReturnValue |
Status information about the latest database operation (select, insert, modify, delete).
(Inherited from DatabaseObject.) | |
SymbolInfo |
Gets or sets the symbol information.
|
Methods
Name | Description | |
---|---|---|
Delete |
Deletes the symbol from the current drawing database.
(Overrides DatabaseObjectDelete.) | |
GetAxisAlignedBoundingBox |
Returns the bounding box of the symbol (rectangle format).
| |
GetDoubleUserProperties(DictionaryString, Double) |
Retrieves all double user properties for the object with the given list of names.
(Inherited from DatabaseObject.) | |
GetDoubleUserProperties(ListString, DictionaryString, Double) |
Retrieves all double user properties for the object with the given list of names.
(Inherited from DatabaseObject.) | |
GetDrawing |
Gets the drawing where the drawing object is.
(Inherited from DrawingObject.) | |
GetIntegerUserProperties(DictionaryString, Int32) |
Retrieves all integer user properties for the object with the given list of names.
(Inherited from DatabaseObject.) | |
GetIntegerUserProperties(ListString, DictionaryString, Int32) |
Retrieves all integer user properties for the object with the given list of names.
(Inherited from DatabaseObject.) | |
GetObjectAlignedBoundingBox |
Returns the bounding box of the symbol (rectangle format).
| |
GetObjects |
Gets the children objects of the current object.
| |
GetObjects(Type) |
Gets the children objects of the current object that are of certain types.
| |
GetRelatedObjects |
Gets the related objects of the current object.
(Inherited from DrawingObject.) | |
GetRelatedObjects(Type) |
Gets the related objects of the current object that are of certain types.
(Inherited from DrawingObject.) | |
GetStringUserProperties(DictionaryString, String) |
Retrieves all string user properties for the object with the given list of names.
(Inherited from DatabaseObject.) | |
GetStringUserProperties(ListString, DictionaryString, String) |
Retrieves all string user properties for the object with the given list of names.
(Inherited from DatabaseObject.) | |
GetUserProperty(String, Double) |
Gets a double property from the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) | |
GetUserProperty(String, Int32) |
Gets an integer property from the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) | |
GetUserProperty(String, String) |
Gets a string property from the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) | |
GetView |
Gets the view where the drawing object is.
(Inherited from DrawingObject.) | |
Insert |
Inserts the symbol into the current drawing database.
(Overrides DatabaseObjectInsert.) | |
IsEqual |
Compares the current object with an object of the same type.
(Overrides DrawingObjectIsEqual(Object).) | |
IsSameDatabaseObject |
Returns true if the current object and the given object are referencing the same database object.
(Inherited from DatabaseObject.) | |
Modify |
Modifies the symbol in the current drawing database.
(Overrides DatabaseObjectModify.) | |
MoveObjectRelative |
Moves the object using the move vector.
| |
Select |
Selects the symbol from the current drawing database.
(Overrides DatabaseObjectSelect.) | |
SetUserProperty(String, Double) |
Sets a double property for the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) | |
SetUserProperty(String, Int32) |
Sets an integer property for the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) | |
SetUserProperty(String, String) |
Sets a string property for the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) | |
ToString |
Changes the string presentation of the drawing object.
(Inherited from DrawingObject.) |
Examples
using Tekla.Structures.Drawing; using Tekla.Structures.Geometry3d; public class Example { public void Example1() { DrawingHandler MyDrawingHandler = new DrawingHandler(); ViewBase view = MyDrawingHandler.GetActiveDrawing().GetSheet().GetAllViews().Current as ViewBase; Symbol xs = new Symbol(view, new Point(1000, 2000), new SymbolInfo("xsteel", 52)); xs.Attributes.Angle = 30; xs.Attributes.Frame.Type = FrameTypes.Rectangular; xs.Attributes.Height = 4.0; xs.Insert(); } }
See Also