SurfaceTreatment Class |
The SurfaceTreatment class defines a layer above a building element defining what a surface looks like.
The surface could for example have a tiled look.
Inheritance Hierarchy
SystemObject
Tekla.Structures.ModelObject
Tekla.Structures.ModelModelObject
Tekla.Structures.ModelSurfaceTreatment
Tekla.Structures.ModelObject
Tekla.Structures.ModelModelObject
Tekla.Structures.ModelSurfaceTreatment
Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The SurfaceTreatment type exposes the following members.
Constructors
Name | Description | |
---|---|---|
SurfaceTreatment |
Creates a new surface treatment instance.
|
Properties
Name | Description | |
---|---|---|
Class |
The class of the surface treatment.
| |
Color |
The color of the surfacing.
| |
CutByFatherBooleans |
Defines if the part is cut by the father's cuts.
| |
EndPoint |
Determines the direction the surfacing is filled in. The direction is from the start point
towards the end point.
| |
Father |
Defines the father part for the surface treatment: the part that the surface treatment is created on.
| |
Identifier |
The identifier of the object.
(Inherited from Object.) | |
IsUpToDate | Gets if the object does not have a modification which is not shared. (Inherited from ModelObject.) | |
Material |
Defines the material for the surface treatment.
| |
ModificationTime | Gets latest time of the object was modified or created. (Inherited from ModelObject.) | |
Name |
The name of the surface treatment.
| |
Polygon |
Defines the area for the surface treatment.
| |
Position |
Defines the position for the surface treatment.
| |
StartPoint |
Determines the origin of the surfacing. The surfacing is then filled out from
the start point towards the end point.
| |
Thickness |
Defines how thick the surface treatment is.
| |
Type |
The type of the surfacing.
| |
TypeName |
The name of the surface treatment type. The valid names are defined in the product_finishes.dat file.
|
Methods
Name | Description | |
---|---|---|
CompareTo |
Compares Identifiers of model objects.
(Inherited from ModelObject.) | |
Delete |
Deletes the surface treatment with the given identifier from the database.
(Overrides ModelObjectDelete.) | |
Equals |
Check if Identifiers of model objects are same.
(Inherited from ModelObject.) | |
GetAllReportProperties |
Retrieves all properties for the model object in one hashtable.
Type for the returned value must be checked using type casting.
(Inherited from ModelObject.) | |
GetAllUserProperties |
Retrieves all properties for the model object in one hashtable.
Type for the returned value must be checked using type casting.
(Inherited from ModelObject.) | |
GetChildren |
Returns an enumerator of all the children model objects.
(Inherited from ModelObject.) | |
GetCoordinateSystem |
Returns the coordinate system for the given model object.
(Inherited from ModelObject.) | |
GetDoubleReportProperties |
Retrieves multiple double report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) | |
GetDoubleUserProperties |
Retrieves all double properties for the model object.
(Inherited from ModelObject.) | |
GetDynamicStringProperty |
Gets a dynamic string property from the model object.
(Inherited from ModelObject.) | |
GetFatherComponent |
Returns the father component of the model object.
(Inherited from ModelObject.) | |
GetHierarchicObjects |
Returns an enumerator of all the connected hierarchic objects.
(Inherited from ModelObject.) | |
GetIntegerReportProperties |
Retrieves multiple integer report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) | |
GetIntegerUserProperties |
Retrieves all integer properties for the model object.
(Inherited from ModelObject.) | |
GetPhase |
Retrieves the phase of the model object (the phase number, the phase name,
the phase comment and whether the phase is the current one or not).
(Inherited from ModelObject.) | |
GetReportProperty(String, Double) |
Retrieves a double property of the report for the model object.
(Inherited from ModelObject.) | |
GetReportProperty(String, Int32) |
Retrieves an integer property of the report for the model object.
(Inherited from ModelObject.) | |
GetReportProperty(String, String) |
Retrieves a string property of the report for the model object.
(Inherited from ModelObject.) | |
GetStringReportProperties |
Retrieves multiple string report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) | |
GetStringUserProperties |
Retrieves all string properties for the model object.
(Inherited from ModelObject.) | |
GetUserProperty(String, Double) |
Retrieves a double property for the model object.
(Inherited from ModelObject.) | |
GetUserProperty(String, Int32) |
Retrieves an integer property for the model object.
(Inherited from ModelObject.) | |
GetUserProperty(String, String) |
Retrieves a string property for the model object.
(Inherited from ModelObject.) | |
Insert |
Inserts the surface treatment to the database.
(Overrides ModelObjectInsert.) | |
Modify |
Modifies the surface treatment with the given identifier in the database to match
the current one.
(Overrides ModelObjectModify.) | |
Select |
Selects the surface treatment with the given identifier.
(Overrides ModelObjectSelect.) | |
SetDynamicStringProperty |
Sets a dynamic string property for the model object.
(Inherited from ModelObject.) | |
SetLabel |
Sets a label for an object when a new instance is created, this method must be called before Insert.
The label is used in plug-ins for identifying the changed object in modification.
(Inherited from ModelObject.) | |
SetPhase |
Sets the phase of the model object.
(Inherited from ModelObject.) | |
SetUserProperties |
Sets multiple properties for the model object.
(Inherited from ModelObject.) | |
SetUserProperty(String, Double) |
Sets a double property for the model object.
(Inherited from ModelObject.) | |
SetUserProperty(String, Int32) |
Sets an integer property for the model object.
(Inherited from ModelObject.) | |
SetUserProperty(String, String) |
Sets a string property for the model object.
(Inherited from ModelObject.) |
Examples
using Tekla.Structures.Model; using Tekla.Structures.Geometry3d; public class Example { public void Example1() { ContourPlate cp = new ContourPlate(); cp.Profile.ProfileString = "PL10"; cp.Class = "3"; cp.AddContourPoint(new ContourPoint(new Point( 6000, 6000,0),null)); cp.AddContourPoint(new ContourPoint(new Point( 9000, 6000,0),null)); cp.AddContourPoint(new ContourPoint(new Point( 9000, 12000,0),null)); cp.AddContourPoint(new ContourPoint(new Point(10500, 15000,0),null)); cp.AddContourPoint(new ContourPoint(new Point( 6000, 12000,0),null)); Contour c = new Contour(); c.AddContourPoint(new ContourPoint(new Point( 6000, 6000,5), null)); c.AddContourPoint(new ContourPoint(new Point( 9000, 6000,5), null)); c.AddContourPoint(new ContourPoint(new Point( 9000, 12000,5), null)); c.AddContourPoint(new ContourPoint(new Point(10500, 15000,5), null)); c.AddContourPoint(new ContourPoint(new Point( 7500, 12000,5), null)); cp.Insert(); SurfaceTreatment treatment = new SurfaceTreatment(); treatment.Father = cp; treatment.Polygon = c; treatment.StartPoint = new Point(1500,0000,0); treatment.EndPoint = new Point(1500,6000,0); bool Result = false; Result = treatment.Insert(); } }
See Also