SurfaceObject Class |
The SurfaceObject class represents a surface object in the model. Currently this class
only support dynamic surfaces whose geometries are determined by the parts or pours
they associate to. It is not allowed to modify the geometry of a dynamic surface on Open API.
The polymesh setter of this class throws .
Inheritance Hierarchy
SystemObject
Tekla.Structures.ModelObject
Tekla.Structures.ModelModelObject
Tekla.Structures.ModelSurfaceObject
Tekla.Structures.ModelRebarLegSurfaceObject
Tekla.Structures.ModelObject
Tekla.Structures.ModelModelObject
Tekla.Structures.ModelSurfaceObject
Tekla.Structures.ModelRebarLegSurfaceObject
Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The SurfaceObject type exposes the following members.
Constructors
Name | Description | |
---|---|---|
SurfaceObject |
Initializes a new instance of the SurfaceObject class.
|
Properties
Name | Description | |
---|---|---|
Class |
Gets or sets the class of the surface object.
| |
CreateHoles |
Gets or sets a value indicating whether CreateHoles parameter of the surface object.
| |
Father |
Gets or sets the father object of the surface object. The father can be set only before the Insert(), otherwise exception is thrown.
| |
Identifier |
The identifier of the object.
(Inherited from Object.) | |
IsUpToDate | Gets if the object does not have a modification which is not shared. (Inherited from ModelObject.) | |
ModificationTime | Gets latest time of the object was modified or created. (Inherited from ModelObject.) | |
Name |
Gets or sets the name of the surface object.
| |
Polymesh |
Gets or sets the surface geometry brep.
| |
Type |
Gets or sets the type of the surface object.
|
Methods
Name | Description | |
---|---|---|
CompareTo |
Compares Identifiers of model objects.
(Inherited from ModelObject.) | |
Delete |
Deletes the model object from the model database.
(Overrides ModelObjectDelete.) | |
Equals |
Check if Identifiers of model objects are same.
(Inherited from ModelObject.) | |
GetAllReportProperties |
Retrieves all properties for the model object in one hashtable.
Type for the returned value must be checked using type casting.
(Inherited from ModelObject.) | |
GetAllUserProperties |
Retrieves all properties for the model object in one hashtable.
Type for the returned value must be checked using type casting.
(Inherited from ModelObject.) | |
GetChildren |
Returns an enumerator of all the children model objects.
(Inherited from ModelObject.) | |
GetCoordinateSystem |
Returns the coordinate system for the given model object.
(Inherited from ModelObject.) | |
GetDoubleReportProperties |
Retrieves multiple double report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) | |
GetDoubleUserProperties |
Retrieves all double properties for the model object.
(Inherited from ModelObject.) | |
GetDynamicStringProperty |
Gets a dynamic string property from the model object.
(Inherited from ModelObject.) | |
GetFatherComponent |
Returns the father component of the model object.
(Inherited from ModelObject.) | |
GetHierarchicObjects |
Returns an enumerator of all the connected hierarchic objects.
(Inherited from ModelObject.) | |
GetIntegerReportProperties |
Retrieves multiple integer report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) | |
GetIntegerUserProperties |
Retrieves all integer properties for the model object.
(Inherited from ModelObject.) | |
GetPhase |
Retrieves the phase of the model object (the phase number, the phase name,
the phase comment and whether the phase is the current one or not).
(Inherited from ModelObject.) | |
GetReportProperty(String, Double) |
Retrieves a double property of the report for the model object.
(Inherited from ModelObject.) | |
GetReportProperty(String, Int32) |
Retrieves an integer property of the report for the model object.
(Inherited from ModelObject.) | |
GetReportProperty(String, String) |
Retrieves a string property of the report for the model object.
(Inherited from ModelObject.) | |
GetStringReportProperties |
Retrieves multiple string report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) | |
GetStringUserProperties |
Retrieves all string properties for the model object.
(Inherited from ModelObject.) | |
GetUserProperty(String, Double) |
Retrieves a double property for the model object.
(Inherited from ModelObject.) | |
GetUserProperty(String, Int32) |
Retrieves an integer property for the model object.
(Inherited from ModelObject.) | |
GetUserProperty(String, String) |
Retrieves a string property for the model object.
(Inherited from ModelObject.) | |
Insert |
Inserts a new model object. The geometry of the object
needs to be set by using the public Polymesh
function, before calling insert.
(Overrides ModelObjectInsert.) | |
Modify |
Modifies the existing model object in the model database to match the current one.
(Overrides ModelObjectModify.) | |
Select |
Selects the model object from the model by the identifier of this instance.
(Overrides ModelObjectSelect.) | |
SetDynamicStringProperty |
Sets a dynamic string property for the model object.
(Inherited from ModelObject.) | |
SetLabel |
Sets a label for an object when a new instance is created, this method must be called before Insert.
The label is used in plug-ins for identifying the changed object in modification.
(Inherited from ModelObject.) | |
SetPhase |
Sets the phase of the model object.
(Inherited from ModelObject.) | |
SetUserProperties |
Sets multiple properties for the model object.
(Inherited from ModelObject.) | |
SetUserProperty(String, Double) |
Sets a double property for the model object.
(Inherited from ModelObject.) | |
SetUserProperty(String, Int32) |
Sets an integer property for the model object.
(Inherited from ModelObject.) | |
SetUserProperty(String, String) |
Sets a string property for the model object.
(Inherited from ModelObject.) |
Examples
using Tekla.Structures.Model; using Tekla.Structures.Geometry3d; using System; using System.Collections; using System.Collections.Generic; public class Example { public void Example1() { Point startPointBeam = new Point(0.0, 0.0, 0.0); Point endPointBeam = new Point(10000.0, 0.0, 0.0); Beam Beam = new Beam(startPointBeam, endPointBeam) { Profile = { ProfileString = "400*400" }, Material = { MaterialString = "Concrete_Undefined" } }; Beam.Insert(); SurfaceObject surfaceObject = new SurfaceObject(); surfaceObject.Polymesh = CreateSingleFacePolymeshGeometry( new[] { new Vector( 0.0, -200.0, 0.0), // 0 new Vector(10000.0, -200.0, 0.0), // 1 new Vector(10000.0, 200.0, 0.0), // 2 new Vector( 0.0, 200.0, 0.0) // 3 }); surfaceObject.Father = this.Beam; surfaceObject.Insert(); } private static FacetedBrep CreateSingleFacePolymeshGeometry(Vector[] vertices) { var outerWires = new int[1][]; outerWires[0] = new int[vertices.Length]; for (int i = 0; i < vertices.Length; i++) outerWires[0][i] = i; var innerWires = new Dictionary<int, int[][]> { }; return new FacetedBrep(vertices, outerWires, innerWires); } }
See Also