StructuresDialogArrayAttribute Class

The StructuresDialogArrayAttribute class specifies the attribute name for which the attributed interface will be used as a list item definition. The attributed interface is used to define the structure of the DataGridView items. In other words it defines all the possible DataGridView columns. The interface is bound to the DataGridView by referencing the interface's attribute name from the DataGridView's Tag property.
Inheritance Hierarchy
SystemObject
  SystemAttribute
    Tekla.Structures.DialogStructuresDialogArrayAttribute

Namespace:  Tekla.Structures.Dialog
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public sealed class StructuresDialogArrayAttribute : Attribute

The StructuresDialogArrayAttribute type exposes the following members.

Constructors
  NameDescription
Public methodStructuresDialogArrayAttribute
Initializes a new StructuresDialogArrayAttribute instance.
Top
Properties
  NameDescription
Public propertyAttributeName
Gets the attribute name of the interface.
Top
Methods
  NameDescription
Public methodToString
Returns a string that represents the current StructuresDialogArrayAttribute object.
(Overrides ObjectToString.)
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next