String Structure

The String datatype.

Namespace:  Tekla.Structures.Datatype
Assembly:  Tekla.Structures.Datatype (in Tekla.Structures.Datatype.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
[SerializableAttribute]
[TypeConverterAttribute(typeof(StringConverter))]
public struct String : IXmlSerializable, IStringDataType, 
	IDataType

The String type exposes the following members.

Constructors
  NameDescription
Public methodString
Creates a new string datatype instance.
Top
Properties
  NameDescription
Public propertyValue
The value of the string datatype.
Top
Methods
  NameDescription
Public methodEquals
Returns a value that indicates whether the current instance is equal to the given object.
(Overrides ValueTypeEquals(Object).)
Public methodGetHashCode
Returns the hash code for the current instance.
(Overrides ValueTypeGetHashCode.)
Public methodGetSchema
Gets the XML Schema for the datatype.
Public methodReadXml
Parses a new value from the given reader.
Public methodToString
Returns the string representation of the object.
(Overrides ValueTypeToString.)
Public methodWriteXml
Writes the value as XML to the given writer.
Top
Operators
  NameDescription
Public operatorStatic memberEquality
Compares a string value with a Datatype.String value.
Public operatorStatic member(String to String)
Converts from string to Datatype.String.
Public operatorStatic member(String to String)
Converts from Datatype.String to string.
Public operatorStatic memberInequality
Compares a string value with a Datatype.String value.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next