![]() | String Structure |
The String datatype.
Namespace: Tekla.Structures.Datatype
Assembly: Tekla.Structures.Datatype (in Tekla.Structures.Datatype.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63

The String type exposes the following members.



Name | Description | |
---|---|---|
![]() | Equals |
Returns a value that indicates whether the current instance is equal to the given object.
(Overrides ValueTypeEquals(Object).) |
![]() | GetHashCode |
Returns the hash code for the current instance.
(Overrides ValueTypeGetHashCode.) |
![]() | GetSchema |
Gets the XML Schema for the datatype.
|
![]() | ReadXml |
Parses a new value from the given reader.
|
![]() | ToString |
Returns the string representation of the object.
(Overrides ValueTypeToString.) |
![]() | WriteXml |
Writes the value as XML to the given writer.
|

Name | Description | |
---|---|---|
![]() ![]() | Equality |
Compares a string value with a Datatype.String value.
|
![]() ![]() | (String to String) |
Converts from string to Datatype.String.
|
![]() ![]() | (String to String) |
Converts from Datatype.String to string.
|
![]() ![]() | Inequality |
Compares a string value with a Datatype.String value.
|