DistanceToString Method (String) |
Creates a string representation of the distance.
Namespace: Tekla.Structures.Datatype
Assembly: Tekla.Structures.Datatype (in Tekla.Structures.Datatype.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
Parameters
- format
- Type: SystemString
The format string.
Return Value
Type: StringThe string representation of the distance.
Examples
This example shows how to specify a number format when converting a
Distance instance to a string.
using Tekla.Structures.Datatype; public class Example { public void Example1() { // For this demonstration, we'll format 300.2 millimeters. Distance distance = new Distance(300.2); // We can use the number format string to specify the precision. In this case, we use two decimal places. string formattedString = distance.ToString("0.00"); } }
See Also