ErrorDialogShow Method (String, ListString, ErrorDialogSeverity)

Shows a new error dialog.

Namespace:  Tekla.Structures.Dialog
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public static void Show(
	string Message,
	List<string> Details,
	ErrorDialogSeverity Severity
)

Parameters

Message
Type: SystemString
The message to display in the dialog.
Details
Type: System.Collections.GenericListString
The details to display in the dialog.
Severity
Type: Tekla.Structures.DialogErrorDialogSeverity
The severity of the message.
Exceptions
ExceptionCondition
ArgumentNullExceptionThrown when the Message parameter is null.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next