RebarHookDataNullableShape Property

Gets or sets the shape of the hook. The options are:
  • NO_HOOK. Sets the angle, radius and length to 0.
  • HOOK_90_DEGREES.
  • HOOK_135_DEGREES.
  • HOOK_180_DEGREES.
  • CUSTOM_HOOK. The angle, radius and length values have to be set manually.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public RebarHookDataRebarHookShapeEnum? Shape { get; set; }

Property Value

Type: NullableRebarHookDataRebarHookShapeEnum
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next