ShapeMetadataTypeEnum Enumeration |
Represents data type or measurement unit of the specific metadata
If this is updated, update ShapeMetadataType_e on the Core side
Namespace: Tekla.Structures.Catalogs
Assembly: Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
Members
Member name | Value | Description | |
---|---|---|---|
Text | 0 | Default value is text | |
DateTime | 10 | Date | |
Integer | 11 | Integer | |
Double | 12 | Double, here precision controlled by TS-> Menu-> Settings-> Options-> Units and decimals -> Modeling -> Factor "XS_UNITDECIMALS_INPUT_FACTOR" | |
Length | 101 | Unit of length, here length refers to TS-> Menu-> Settings-> Options-> Units and decimals -> Catalogs -> Dimension. "XS_UNIT_INPUT_DIMENSION", "XS_UNITDECIMALS_INPUT_DIMENSION" | |
Area | 201 | Unit of area, here area refers to TS-> Menu-> Settings-> Options-> Units and decimals -> Catalogs -> Area. "XS_UNIT_INPUT_AREA", "XS_UNITDECIMALS_INPUT_AREA" | |
Volume | 301 | Unit of volume, here volume refers to TS-> Menu-> Settings-> Options-> Units and decimals -> Catalogs -> Volume. "XS_UNIT_INPUT_VOLUME", "XS_UNITDECIMALS_INPUT_VOLUME" | |
Weight | 401 | Unit of weight, here weight refers to TS-> Menu-> Settings-> Options-> Units and decimals -> Catalogs -> Weight. "XS_UNIT_INPUT_WEIGHT", "XS_UNITDECIMALS_INPUT_WEIGHT" |
See Also