ShapeItemEnumerator Class |
The ShapeItemEnumerator class allows to loop through the shape catalog items.
Inheritance Hierarchy
Namespace: Tekla.Structures.Catalogs
Assembly: Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The ShapeItemEnumerator type exposes the following members.
Properties
Methods
Name | Description | |
---|---|---|
GetSize |
Returns the total amount of items.
| |
MoveNext |
Moves to the next item in the enumerator.
| |
Reset |
Resets the enumerator to the beginning.
|
Examples
The following example returns true if an item with the name Connection has been found:
using Tekla.Structures.Catalogs; public class Example { public bool Example1() { bool Result = false; CatalogHandler CatalogHandler = new CatalogHandler(); if (CatalogHandler.GetConnectionStatus()) { ShapeItemEnumerator ShapeItemEnumerator = CatalogHandler.GetShapes(); while (ShapeItemEnumerator.MoveNext()) { ShapeItem ShapeItem = ShapeItemEnumerator.Current as ShapeItem; if (ShapeItem.Name == "Connection") { Result = true; break; } } } return Result; } }
See Also