ShapeCatalog Class |
The ShapeCatalog class represents a group of controls to select Shapes
using the Shape catalog.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Tekla.Structures.Dialog.UIControlsShapeCatalog
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Tekla.Structures.Dialog.UIControlsShapeCatalog
Namespace: Tekla.Structures.Dialog.UIControls
Assembly: Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The ShapeCatalog type exposes the following members.
Constructors
Name | Description | |
---|---|---|
ShapeCatalog |
Initializes a new instance of the ShapeCatalog class.
| |
ShapeCatalog(String) |
Initializes a new instance of the ShapeCatalog class and will select
the Shape (if available) in the tree.
|
Properties
Name | Description | |
---|---|---|
ButtonText |
Gets and sets the text of the button control.
| |
SelectedShape |
Gets or sets the selected Shape in the control.
|
Methods
Name | Description | |
---|---|---|
OnValueChanged |
Event handler for passing generic catalog data back to dialog
|
Events
Name | Description | |
---|---|---|
SelectClicked |
The SelectClicked event is raised when the Select button is clicked.
| |
SelectionDone |
The SelectionDone event is raised when the selection has been done.
|
See Also