SettingsProxy Class |
The SettingsProxy class is a proxy for the settings.
Inheritance Hierarchy
Namespace: Tekla.Structures.Datatype
Assembly: Tekla.Structures.Datatype (in Tekla.Structures.Datatype.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The SettingsProxy type exposes the following members.
Constructors
Name | Description | |
---|---|---|
SettingsProxy |
Creates a new settings proxy instance.
|
Methods
Name | Description | |
---|---|---|
GetValue |
Gets the value of the setting with the given name.
| |
SetValue |
Sets a setting to a value.
| |
TryGetValue |
Tries to get the value of the setting with the given name.
|
See Also