OBBSetExtent Method (Double, Double, Double)

Sets the extents to the OBB.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public void SetExtent(
	double extent0,
	double extent1,
	double extent2
)

Parameters

extent0
Type: SystemDouble
The extent (half-length) of the side parallel to axis one.
extent1
Type: SystemDouble
The extent (half-length) of the side parallel to axis two.
extent2
Type: SystemDouble
The extent (half-length) of the side parallel to axis three.
Exceptions
ExceptionCondition
ArgumentExceptionThrown when setting the extent fails.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next