OBBSetAxis Method (Vector, Vector, Vector)

Sets the Axis to the OBB.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public void SetAxis(
	Vector axis0,
	Vector axis1,
	Vector axis2
)

Parameters

axis0
Type: Tekla.Structures.Geometry3dVector
Unit-length vector parallel to one axis of the OBB.
axis1
Type: Tekla.Structures.Geometry3dVector
Unit-length vector parallel to the second axis of the OBB.
axis2
Type: Tekla.Structures.Geometry3dVector
Unit-length vector parallel to the third axis of the OBB.
Exceptions
ExceptionCondition
ArgumentExceptionThrown when setting the axis fails.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next