DrawingHandlerSetActiveDrawing Method (Drawing, Boolean)

Sets the active drawing that is currently open in Tekla Structures.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public bool SetActiveDrawing(
	Drawing drawing,
	bool showDrawing
)

Parameters

drawing
Type: Tekla.Structures.DrawingDrawing
The drawing to be set as the active drawing.
showDrawing
Type: SystemBoolean
Whether to open the drawing as visible or in the background (faster).

Return Value

Type: Boolean
True on success.
Exceptions
ExceptionCondition
CannotPerformOperationDrawingNotUpToDateExceptionThrown if the drawing is not up to date.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next