RebarItemSelect Method (String, Double, String, Boolean)

Selects the rebar item in the rebar database.

Namespace:  Tekla.Structures.Catalogs
Assembly:  Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public bool Select(
	string Grade,
	double Diameter,
	string Usage,
	bool UseNominalDiameter
)

Parameters

Grade
Type: SystemString
The grade of the rebar item to select.
Diameter
Type: SystemDouble
The diameter of the rebar item to select.
Usage
Type: SystemString
The usage of the rebar item to select.
UseNominalDiameter
Type: SystemBoolean
If set to false, the item is selected based on the actual diameter. If true, the item is selected based on the nominal diameter.

Return Value

Type: Boolean
True on success.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next