SecondaryTypeAttribute Class |
The SecondaryTypeAttribute class is used for storing the number of needed secondaries in the connection.
Based on the type the system can then correctly ask for user input in the creation.
The attribute is initialized from the custom attribute i.e.
[SecondaryType(ConnectionBase.SecondaryType.SECONDARYTYPE_ONE)]
in the connection source.
Inheritance Hierarchy
Namespace: Tekla.Structures.Plugins
Assembly: Tekla.Structures.Plugins (in Tekla.Structures.Plugins.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The SecondaryTypeAttribute type exposes the following members.
Constructors
Name | Description | |
---|---|---|
SecondaryTypeAttribute(Int32) |
The custom attribute [SecondaryType()] uses this to store the secondary type to the system.
This is not to be used by itself.
| |
SecondaryTypeAttribute(ConnectionBaseSecondaryType) |
The custom attribute [SecondaryType()] uses this to store the secondary type to the system.
This is not to be used by itself.
|
Properties
Name | Description | |
---|---|---|
Type |
The custom attribute [SecondaryType()] uses this to store the secondary type to the system.
This is not to be used by itself.
|
See Also